cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ejprice Frequent Visitor
Frequent Visitor

Q&A doesn't search for terms in long text entities when the term is included in global substitions

Hi!

 

I am having an issue with the Q&A/linguist schema and given how new the features are in powerbi, I have not been able to find a solution. I am attempting to create global synonyms for a word so that in the Q&A engine, users can search for occurances of that word within a field that contains long-text descriptions. As an example, with the Summer Olympics linguistic schema provided by PowerBI, the engine works fine for search within the description field until I include a global substition of "weight" = bantamweight or heavyweight, at which point the Q&A engine no longer searches for this value within the description field. The operator also works fine with the other global substitutions when searching the other fields that are not long form text fields. Output example:

 

no_weight_yaml.PNGtest_no_weight_quote.PNG weight_yaml.PNGtest_weight_no_quote.PNGtest_weight_quote.PNG

 

Has anyone else encountered this issue? Am I doing something wrong or not understanding this functionality correctly? Does anyone have a solution or a workaround? When I first created the substitutions is was searching for all the words, but it was doing so in a random column and as I was troubleshooting, this problem started happeing. Any and all help is appreciated!

 

Thanks,

Emma

2 REPLIES 2
v-jiascu-msft Super Contributor
Super Contributor

Re: Q&A doesn't search for terms in long text entities when the term is included in global subst

Hi @ejprice,

 

Can you share your file? It seems good in my test.

Q_A_doesn_t_search_for_terms_in_long_text_entities_when_the_term_is_included_in_global_subst

 

Best Regards,

Dale

Community Support Team _ Dale
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
ejprice Frequent Visitor
Frequent Visitor

Re: Q&A doesn't search for terms in long text entities when the term is included in global subst

Hi!

 

A link to the pbix file and the yaml file here: https://drive.google.com/drive/folders/188lWjprk_Vb2DaBZZy-ViQsQyFKlPDMi?usp=sharing

 

The issue is pretty specific to searching long-text fields with a term that is not found in other fields (otherwise PowerBI knows to look at these fields). The issue is also not really relevant/useful with the test data, but a bigger issue on the data that I'm using which has multiple long-tex fields.

Helpful resources

Announcements
Back to School Contest

Back to School Contest

Engage and empower students with Power BI!

MBAS Gallery

Watch Sessions On Demand!

Continue your learning in our online communities.

Summit Australia 2019

Summit Australia 2019

Travel to Melbourne and network with thousands of peers!

PBI Community Highlights

PBI Community Highlights

Check out what's new in the Power BI Community!

Top Ideas
Users Online
Currently online: 42 members 1,039 guests
Please welcome our newest community members: