cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
michaelccdf Regular Visitor
Regular Visitor

Putting +0 into Values field

I have a matrix which counts the distinct number of employees by language group and year.  There are some cells that are blank as they do no have any employees in that particular year.  If I use a DAX formula as the measure for this matrix

 

 

Employee Count = DISTINCTCOUNT(fait_employee_retention[MATR])+0

 

 

then the 0's appear in empty cells as expected.  However, I lose the ability to do Show Records.  Is there some way to add +0 to the Values field instead of using a measure?

value.png

1 ACCEPTED SOLUTION

Accepted Solutions
michaelccdf Regular Visitor
Regular Visitor

Re: Putting +0 into Values field

I'm trying to do this without using a "custom" measure, but instead using the default "measure" that is created when you drag a column into the Values box.  I can use a custom measure to achieve this (simply adding +0 at the end of the formula), but when I use a custom measure, I no longer have the option to See Records.

View solution in original post

4 REPLIES 4
Community Support Team
Community Support Team

Re: Putting +0 into Values field

Hi @michaelccdf,

 

Does the option "show items with no data" work?

 

2.PNG

 

Regards,

Frank

Community Support Team _ Frank
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
michaelccdf Regular Visitor
Regular Visitor

Re: Putting +0 into Values field

Thanks Frank.  It shows the items but as blanks instead of 0's

Super User
Super User

Re: Putting +0 into Values field

@michaelccdf Please try like this in your Measure. Along with "Show items with no data" option.

 

EmpCount = IF(ISBLANK(DISTINCTCOUNT(_Emp[EMPNO])),0,DISTINCTCOUNT(_Emp[EMPNO]))

image.png



Did I answer your question? Mark my post as a solution !

Proud to be a Datanaut !





michaelccdf Regular Visitor
Regular Visitor

Re: Putting +0 into Values field

I'm trying to do this without using a "custom" measure, but instead using the default "measure" that is created when you drag a column into the Values box.  I can use a custom measure to achieve this (simply adding +0 at the end of the formula), but when I use a custom measure, I no longer have the option to See Records.

View solution in original post

Helpful resources

Announcements
Can You Solve These Challenge

Challenge: Can You Solve These?

Find out how to participate in the first Power BI 'Can You Solve These?' challenge.

New Badges

Incoming: New and Improved Badges

Exciting news: We've given our badges an overhaul and added brand news ones.

Ask Amir Anything

Exclusive LIVE Community Event No. 2 – Ask Amir Anything

Next in our Triple A series: Ask Amir Netz questions about the latest updates, features and future.

Analytics in Azure virtual event

Analytics in Azure virtual event

Experience a limitless analytics service built to ingest, prep, manage, and serve data for immediate use in Power BI.

Users Online
Currently online: 349 members 3,258 guests
Please welcome our newest community members: