cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mag22
New Member

Publishing is complete. However we couldn't refresh your dataset.

Hello, I have been getting this error whenever I publish from desktop. Most of the content is shared as expected. However, the date in one of the filters is not being updated when I publish. It updates in the desktop but then needs to be manually updated in the online dashboard. Has been happening for about about a week, which means every day, users have to update more dates in the filter to be up to date. Any advice would be great, thank you!

 

 

Error.PNG

1 ACCEPTED SOLUTION
v-deddai1-msft
Community Support
Community Support

Hi @mag22 ,

 

Would you please try to clear cache before your publish it to the power bi desktop?

 

File -> Options and Settings -> Options -> Data Load 

Then Clear the

1. Data Cache Management Options

2. Q&A Cache Options

3. Folded Artifacts Cache Options

 

And you can refer to the similar post, there are many other workaround for you to try.  https://community.powerbi.com/t5/Desktop/publishing-is-complete-however-we-couldn-t-refresh-your-dat...

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Best Regards,

Dedmon Dai

View solution in original post

2 REPLIES 2
v-deddai1-msft
Community Support
Community Support

Hi @mag22 ,

 

Would you please try to clear cache before your publish it to the power bi desktop?

 

File -> Options and Settings -> Options -> Data Load 

Then Clear the

1. Data Cache Management Options

2. Q&A Cache Options

3. Folded Artifacts Cache Options

 

And you can refer to the similar post, there are many other workaround for you to try.  https://community.powerbi.com/t5/Desktop/publishing-is-complete-however-we-couldn-t-refresh-your-dat...

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Best Regards,

Dedmon Dai

View solution in original post

Allisond
Advocate II
Advocate II

I am getting the same error on 2 of my reports.  I worked around the first by deleting and republishing - it was an isolated report.  On my second, however, this causes a lot of extra work.  I will have to re-add visuals to dashboards and copy the report to the connected workspaces, edit those reports for the app publication again, etc..    Any help in how to correct without having to delete on the service and republish would be Greatly appreciated. 

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

July 2021 Update 768x460.png

Check it out!

Click here to read more about the July 2021 Updates

Top Solution Authors
Top Kudoed Authors