cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
kalleeljas Frequent Visitor
Frequent Visitor

Problem with merge, "Value was not specified" error

Hello.

 

Im trying to merge two tables to create a uniqe ID from customernumber and product.

The table "ANLÄGGNINGAR" contain the ID i want to use (column "Cistern").

 

The example below is a successful merge (i get the ID from "ANLÄGGNINGAR" into "Garplev") that i would like to do on another table:

correct merge

 

In the example below im trying to merge "Sitevision" and "ANLÄGGNINGAR" but i cant even see the 2nd table with the error message "Value was not specified"

merge fel

 

Note that i can merge from "sitevision" to "ANLÄGGNINGAR" but not the other way around. The problem is that i dont understand what "Value was not specified" means.

1 ACCEPTED SOLUTION

Accepted Solutions
v-micsh-msft New Contributor
New Contributor

Re: Problem with merge, "Value was not specified" error

Hi kalleeljas,

 

Could you please share us some simple data about the "Sitevision" and "ANLÄGGNINGAR" tables?

I created some simple table to test and can’t reproduce the error, this should not be related with the join option selected. Please check the table information first, which I suspect the key point should be the "ANLÄGGNINGAR" table.

In addition, check your Power BI desktop version, make sure it is up-to-date.

The latest version is available in the following link:

https://powerbi.microsoft.com/en-us/desktop/

Regards

 

4 REPLIES 4
Super User
Super User

Re: Problem with merge, "Value was not specified" error

Hi there,

 

The reason behind this is that The LEFT JOIN returns all rows from the left table (table1), with the matching rows in the right table (table2). The result is NULL in the right side when there is no match and PowerQuery smart sense doesn't even let you create that join if the condition for that is not met.

 

Hope this has clarified your understanding of left join.

Thanks & Regards,
Bhavesh

Love the Self Service BI.
Please use the 'Mark as answer' link to mark a post that answers your question. If you find a reply helpful, please remember to give Kudos.
v-micsh-msft New Contributor
New Contributor

Re: Problem with merge, "Value was not specified" error

Hi kalleeljas,

 

Could you please share us some simple data about the "Sitevision" and "ANLÄGGNINGAR" tables?

I created some simple table to test and can’t reproduce the error, this should not be related with the join option selected. Please check the table information first, which I suspect the key point should be the "ANLÄGGNINGAR" table.

In addition, check your Power BI desktop version, make sure it is up-to-date.

The latest version is available in the following link:

https://powerbi.microsoft.com/en-us/desktop/

Regards

 

Highlighted
kristen Regular Visitor
Regular Visitor

Re: Problem with merge, "Value was not specified" error

I worked around this error by "Merging Queries as New" instead of just a merge. It's not really a solution but it allowed me to get around the join problem!

kalleeljas Frequent Visitor
Frequent Visitor

Re: Problem with merge, "Value was not specified" error

I made a workaround to solve the problem, I tried again recently with an updated version of PBI desktop and It worked.