cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
YigitK
Frequent Visitor

PowerBI Won't Open IDE for Python (Visual Studio)

I saw a similar post from the past but it was never resolved, I'm wondering if anyone else is running into similar issues.

 

I have installed PowerBI and Visual Studio Code, installed Python and Python extension for VS Code. VS code is set as default application for opening .py files. 

 

When I go to Python settings VS Code doesn't appear in drop-down as an installed IDE. When I ask PBI to use the default app for .py extensions or manually point to VS Code's executable, it still ignores the whole thing and just opens the built-in Python editor.

 

Am I missing something or this is a bug? 

 

Thanks 

1 ACCEPTED SOLUTION

Hi, @YigitK 

You can try the following steps.

 

1 Select Python visual from Visualizations Pane to enable scripts visual

v-cazheng-msft_0-1614230382442.png

 

2 Drag a field into Python visual as values and then click the arrow to enable script in external IDE

v-cazheng-msft_1-1614230382489.png

 

v-cazheng-msft_3-1614230641193.png

 

 

Best Regards,

Caiyun Zheng

 

Is that the answer you're looking for? If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

View solution in original post

7 REPLIES 7
v-cazheng-msft
Community Support
Community Support

Hi, @YigitK 

You can refer Run Python scripts in Power BI Desktop and Use an external Python IDE with Power BI. If it doesn't work, you can consider downloading Python from Python website and installing it.

 

Best Regards,

Caiyun Zheng

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Latest supported version of Python is installed and I've already followed the steps in the documentation. It simply doesn't work.

 

Hi, @YigitK 

Can you describe your configuration steps with more details? Does your setting for Python in Options looks like the following?

 

v-cazheng-msft_0-1614074160210.png

 

Best Regards,

Caiyun Zheng

 

Python scripts do run but IDE doesn't launch. I'm pointing it to VS Code executable as it doesn't appear on the detected IDE drop-down. image.png

Hi, @YigitK 

Your configuration in Options is correct. Then you need click the arrow to enable VS Code. Have you operated like this?

v-cazheng-msft_0-1614133880892.png

 

Best Regards,

Caiyun Zheng

I don't see the arrow or syntax highlighting. Tried both in get data and Query Editor windows.


 

YigitK_2-1614174558607.png

 

Hi, @YigitK 

You can try the following steps.

 

1 Select Python visual from Visualizations Pane to enable scripts visual

v-cazheng-msft_0-1614230382442.png

 

2 Drag a field into Python visual as values and then click the arrow to enable script in external IDE

v-cazheng-msft_1-1614230382489.png

 

v-cazheng-msft_3-1614230641193.png

 

 

Best Regards,

Caiyun Zheng

 

Is that the answer you're looking for? If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

View solution in original post

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Top Solution Authors
Top Kudoed Authors