cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
agurupra
Frequent Visitor

Power bi Report Permissions - ssas tabular

Hello Friends,

 

How do I grant "All people within my organization" Powerbi Report permissions on the SSRS Reporting Server? The reason being that the powebi Report should be viewable by any department i.e Business Analysts, HR, PM Office etc.

 

Below is my PowerBI setup scenario

  • SSRS Reporting Services 2016
  • Power BI Report Server - May 2017 Preview vNext ( On-premises Report Server). I have set this up on a different instance within the same Reporting Server.
  • Power BI Desktop comptabile with May 2017 Preview.
  • Database Engine 2016
  • SSAS Tabular Model
  • Visual Studio Data Tools 2015
  • Developed Power BI Report in PowerBI Desktop and uploaded to SSRS Instance.

 

Do I need to give Read permissions to the AD Group "NT Authority\Authenticated Users" or "<Domain>\Domain Users" for 

  1. SSAS Role ?
  2. or PowerBI Report on SSRS -> Manage - > Security -> Browser Permissions

 

Abhi

 

1 ACCEPTED SOLUTION

hi @agurupra

 

Can the users at least get to the SSRS report server?

 

If they can then yes the next step is to make sure that they can indeed access the SSAS Tabular Server. Have you added the AD Groups into a Role on your SSAS model?





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

View solution in original post

9 REPLIES 9
aghonaim
MVP

Would it be possible to add all users in the domain without specifying them one by one ?

Yes. Add <DOMAIN>\Domain Users in the "Security" of the PowerBI Report. After which, any user in your Domain should be able to view the report.

 

 

GilbertQ
Super User II
Super User II

Hi @agurupra

 

In my experience in the past I have given access to 'Domain\Domain Users'





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Hey @GilbertQ

No luck with the mentioned AD Group. Even gave a specific user explicit access. Says permission denied. Does SSAS also require read permissions for Domain Users. I believe the data source permissions to access database should be good enough.

hi @agurupra

 

Can the users at least get to the SSRS report server?

 

If they can then yes the next step is to make sure that they can indeed access the SSAS Tabular Server. Have you added the AD Groups into a Role on your SSAS model?





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

View solution in original post

@GilbertQ

 

Finally, It works now .

 

Followed your suggestion and re-added the <Domain>\Domain Users on the Site Settings as System User.

 

Thanks man.

Abhi

Hi Abhi,

   I'm also facing the same issue, Added roles in ssas tabular model like Role1:with full permissions and in membership i added domain\user1,domain\user2 

and Role2: read permission ,membershp:domain\user3 with rowfilters: iadded some condition.

 

i'm thetabular model source to powerbi report in powerbi report server & published to reportserver.

do i get the roles refelected in powerbi reportserver from tabulamodel or do i need to add domain\user1,2,3 on the sitesettings as u mentioned..

Pls help..

Hey srilakshmi12,

 

I just happend to see this message. 

 

After this post I had tweaked my Power BI settings the below way.

 

SSAS

1) Created a service account. ( Ex: DOMAIN\Srvc1 )

2) Connected to the model with the above service account. Make sure the service account has appropriate permissions w.r.to your organization. 

3) Deploy the model to SSAS Server. 

 

Power BI Report Server

1) Install Power BI Report Server - On premise

2) Install related version of Power BI Desktop

3) Create and deploy reports to Power BI Report Server

4) Once Power BI Report is uploaded / Save as to Report Server, navigate to Data Source on the Report Server URL. In the Data Source Tab , make sure use the DOMAIN\Srvc1 account as the login credentials.  

5) Navigate to Security Tab. Grant "Browser" permissions to <DOMAIN>\Domain Users. Example if the Domain is Microsoft, the security group is MICROSOFT\Domain Users.

6) Navigate to Site Settings. Grant "System User" permissions to <DOMAIN>\Domain Users. Example if the Domain is Microsoft, the security group is MICROSOFT\Domain Users.

 

This should work. If the above does not work, also try adding the service account to the SSAS Server. 

Let me know if I can be of any further help.

Abhi

Awesome glad you got it working.





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Get Ready for Power BI Dev Camp

Power BI Dev Camp - June 24th

Mark your calendars and join us for our next Power BI Dev Camp!

Top Solution Authors
Top Kudoed Authors