cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
harryhaller Frequent Visitor
Frequent Visitor

Power BI data source SSAS Tabular Model via Localhost not working

Hi there,

 

Short Version

I'm connecting to my tabular model via localhost:[portnumber], which used to work fine over the past months, but am experiencing difficulties now (report crashes) - anybody with similar problem / solution to this?

 

Long Version

I've been using a SSAS Tabular Model as source for my PBI report "locally" as I don't have an actual SSAS Instance installed on a SQL server yet - meaning for the data source settings

  • server: localhost:12345 (the port changes every time I close&open Visual Studio and I have to re-enter the current port number in PBI)
  •  database: TabularProject2_MYUSERNAME_fd6a2703-ae06-49c2-923c-def99da059cd
  •  Mode: Connect Live

 

I've been doing this as I got started with SSAS and PBI and it worked like a charm (just had to adjust the port number upon opening). My thought was then to, once I have my SSAS Instance, deploy the tabular model there and just change the server and database name in my PBI report.

 

Now the problem: since a couple of days this stopped working and actually caused all my reports set up in that way to crash upon opening, precisely

 

1. error message that "unable to connect" (this is normal)

 

capt1.PNG

 

2. I change the portnumber to the correct one (this is normal - and yes, it's the correct port number)

 

capt2.PNG

 

3. Power BI Desktop goes into some state of apathy and doesn't load the ribbons nor show my report (THIS is the issue)

 

capt3.PNG

 

 

My Setup

  • Visual Studio 2015 Community Version
  • Power BI Desktop 2.50.4859.502 64-bit (September 2017) - Pro Account
  • Tabular Model 2016 (RTIM 1200)

 

What I've already tried (and did not work/help)

  • created new/different datamodels and reports (my initial thought was that my report and datamodel grew too complex/big)
  • zipped/unzipped the pbix file into a folder and exchanged some of the xml etc. files (zipping back and renaming to .pbix throws error when trying to open w Power BI - didn't surprise me though)
  • old versions of the same report(s)

 

Using "Import" instead of the live connection does the job, but then I can't change back to "live connection" at a later point. My aim is to build datamodel and report, so to have it ready once I get my server and then deploy rather quickly. The report grew quite extensive over multiple pages and what would already help me is if I could recover what I did so far (not just out of laziness, but also since I don't remember everything in detail...)

 

Any ideas?

 

Thanks in advance & best regards

Felix

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
harryhaller Frequent Visitor
Frequent Visitor

Re: Power BI data source SSAS Tabular Model via Localhost not working

Thanks to MS PBI Support we were able to find a solution, which I'd like to share here.

 

Cause

The CEF component (https://en.wikipedia.org/wiki/Chromium_Embedded_Framework) created this issue

 

Solution

  1. Uninstall PBI Desktop
  2. Delete the “CEF” folders in %LOCALAPPDATA% i.e. in Windows 7 (replace “USERNAME” with your windows account)
    1. C:\Users\USERNAME\AppData\Local
    2. C:\Users\USERNAME\AppData\Local\Microsoft\Power BI Desktop
  3. Restart Computer (just to be sure)
  4. Install latest version of PBI Desktop

 

This works for me so far – hope it helps you, too, in case you experience the same issue.

 

Still thanks to @vanessafvg for the ideas and help!

6 REPLIES 6
Super User
Super User

Re: Power BI data source SSAS Tabular Model via Localhost not working

@harryhaller not sure if it will help at all but have you tried using dax studio?

 

have you cleared out your cache?

what is your memory doing?

 

https://www.sqlbi.com/tools/dax-studio/


Did I answer your question? Mark my post as a solution.
Proud a to be a Datanaut!
harryhaller Frequent Visitor
Frequent Visitor

Re: Power BI data source SSAS Tabular Model via Localhost not working

Thank you - got DAXStudio and cleared cache, but no change

 

--> what do you mean re the memory? (if below screenshot of the Model.bim Properties helps - says "unload from memory")

 

capt4.PNG

Super User
Super User

Re: Power BI data source SSAS Tabular Model via Localhost not working

@harryhaller how much memory do you have available on the machine you using?  have you checked  your task manager to see if you have enough memory?  check your memory performance.   process of elimination really

 

 


Did I answer your question? Mark my post as a solution.
Proud a to be a Datanaut!
harryhaller Frequent Visitor
Frequent Visitor

Re: Power BI data source SSAS Tabular Model via Localhost not working

Thanks to MS PBI Support we were able to find a solution, which I'd like to share here.

 

Cause

The CEF component (https://en.wikipedia.org/wiki/Chromium_Embedded_Framework) created this issue

 

Solution

  1. Uninstall PBI Desktop
  2. Delete the “CEF” folders in %LOCALAPPDATA% i.e. in Windows 7 (replace “USERNAME” with your windows account)
    1. C:\Users\USERNAME\AppData\Local
    2. C:\Users\USERNAME\AppData\Local\Microsoft\Power BI Desktop
  3. Restart Computer (just to be sure)
  4. Install latest version of PBI Desktop

 

This works for me so far – hope it helps you, too, in case you experience the same issue.

 

Still thanks to @vanessafvg for the ideas and help!

Super User
Super User

Re: Power BI data source SSAS Tabular Model via Localhost not working

@harryhaller interesting!  so far of the charts i would never have known. glad its sorted (and weve both learnt somethings new)


Did I answer your question? Mark my post as a solution.
Proud a to be a Datanaut!
Highlighted
mazharmh Member
Member

Re: Power BI data source SSAS Tabular Model via Localhost not working

Hi all,

 

 

Thanks for the information provided in screen shot, it was  really helpful.