cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Regular Visitor

Power BI Desktop Refresh Slow

I just upgraded to the latest Power BI Desktop Version: 2.32.4307.522 64-bit (February 2016).

 

Since the upgrade, when i attempt to Refresh the data from SQL Server, the application loads the rows from the table(s) and then just hangs for about 5-10 minutes. (Even for a small data set like 1000 rows.) After some time the application will then complete the refresh.

 

Anyone know whats going on here?

 

-jillian

1 ACCEPTED SOLUTION

Accepted Solutions

@jillian, one other thing to turn off (just to diagnose) in the settings dialog:

Current File->Data Load->Auto Date/Time

 

With this off, try refresh again

View solution in original post

14 REPLIES 14
Microsoft
Microsoft

@jillian can you elaborate what "hangs for 5-10 mins" mean? Is it responsive to mouse input (like dragging), is there a status dialog displaying what it is doing? Can you take a screenshot of the hang?

Power BI Desktop just "hangs" with spinning icons for ~5mins while refreshing. Here is a screenshot showing the load. The mouse and other applications still work fine but the Power BI desktop application is frozen waiting. It's doing this across multiple .pbix files and even on ones with a very small dataset. It started happening after this latest version from yesterday evening.

 

I've tried re-installing the application and a clean reboot and still seeing this behavior.

 

PowerBI Refresh Hang.png

 

-jillian

@jillian are the numbers for any of these queries moving?

 

If you go to the Task Manager, how many Microsoft.Mashup.Container*.exe can you find there, and are any of them busy?

Have you tried to disable relationship detection in the settings dialog?

The data changes once per hour for this particular dataset. The entire .pbix is only 3.8MB including the data. I'm currently seeing 3x Microsoft.Mashup.Container.NetFX40.exe's running.

 

I tried disabling both Import / Autodetect Relationships as well as disabling Type Detection. I'm seeing the same slowness on this latest build.

 

-jillian

@jillian, one other thing to turn off (just to diagnose) in the settings dialog:

Current File->Data Load->Auto Date/Time

 

With this off, try refresh again

View solution in original post

I disabled Data Load -> Auto Date/Time and voila! That fixed it!

Thank you. Wonder what changed in the latest build that's causing this. I havent ran into this problem before.

@jillian Well that only explains the reason, not the cause. We'll investigate this internally.

 

I'm guessing your data probably have many columns of date/time type, so behind the scenes we are trying to create a date table automatically, which takes time. Disabling the auto date/time feature means you'll probably need to manually create a date table in the model. There are many ways to do this, and many posts about it on this forum.

 

Regards,

PQ

Regular Visitor

Hi there, I've tried all the things mentioned in this post and my refresh still takes around half an hour (used to take around 15 seconds). Running latest version of Power BI Desktop. Any ideas?

Me too ... What's up here?

Helpful resources

Announcements
November Update

Check it Out!

Click here to read more about the November 2020 Updates!

Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

secondImage

Power Platform October Community Highlights

Check out the top community contributors across all of the communities

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors
Top Kudoed Authors