Showing results for 
Search instead for 
Did you mean: 
Advocate II
Advocate II

Power BI Desktop Publish Button Disabled - Possible regression bug

Posting this as a new thread to avoid any confusion, as I just realized the old thread was marked solved.


The Power BI Publish button is greyed out in the desktop app.  I've duplicated this on two different systems with two of our accounts.


One test was done by downloading normally the latest desktop version from  The test on the other machine was done by installing via the Windows 10 store app and allowing it to receive updates.  Same result both systems.  


No problem logging into either the desktop app, or the online service, it's just that the Publish button is disabled in the desktop app.


PBI Desktop Version: 2.57.5068.721 64-bit (April 2018)

Windows 10 Version: 10.0.16299.402


Wth? I'm missing something obvious?

Not applicable

If you don't have any data in the report, it will be grayed out. I had this happen when I just wanted to publish a simple mock report. Simply added a custom table in the query editor and then I could publish.

Hi @Cubist,


Can you share some snapshots and a pbix file? It seems good.


Best Regards,


Community Support Team _ Dale
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

PBI_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!