cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Richard11
Frequent Visitor

Power Apps for Power BI: Error getting environments

Hi,

 

when i insert Power Apps component to Power BI report. I'm getting following error "Error getting environments". Issues persist for more than one week. I tried to update Power BI desktop and edit the report in browser editor and get the same result. Does anyone met the same issue..?

 

Thank you for help..!

 

 

1 ACCEPTED SOLUTION
narcislascu88
Frequent Visitor

I've found a workaround - if you have the same powerapp visual working in another report you can copy it to you current report, replace the fields or what other errors you get and the embedded app will work. 

View solution in original post

9 REPLIES 9
Crowie
New Member

Just checked, and this is now automagically working again on my end, at least.

Crowie
New Member

I'm having the same issue in different client tenants, and in both Edge and Chrome. Is there any solution to this yet?

Nimai123
Post Patron
Post Patron

Hello @Richard11  @Nappa @henrychr 

 

You are getting this error due to some backend connectivity issue either with the Power BI or PowerApps.

 

Solution 1: You can try to re-create the environment.

Solution 2: You can raise a support ticket with the power BI so that they can help you to understand what's causing the problem in the backend!

 

If you are a pro user you can create a support ticket for free.

 

Regards,

 

IF YOU LIKE MY ANSWER PLEASE GIVE A KUDOS AND IF IT HELPS YOU TO GET A SOLUTION MARK IT AS A SOLUTION

henrychr
Frequent Visitor

I am also getting this error, it's persisted for a few days.

 

Nappa
New Member

I am getting the same error along with my colleagues, very frustrating as clients reports are not working.

 

Nappa_0-1604664450566.png

 

narcislascu88
Frequent Visitor

I've found a workaround - if you have the same powerapp visual working in another report you can copy it to you current report, replace the fields or what other errors you get and the embedded app will work. 

View solution in original post

narcislascu88
Frequent Visitor

Here is a screenshot of the error

narcislascu88_1-1604644522182.png

 

narcislascu88
Frequent Visitor

I have the same issue for a couple of days now. Is there a solution to this?

V-pazhen-msft
Community Support
Community Support

@Richard11 

Could you show an screenshot of the error?

When you use PowerApps, which account do you connect to?

Check the limitations here to find whether you meet any point.


Paul Zheng _ Community Support Team
If this post helps, please Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
User Groups Public Preview

Join us for our User Group Public Preview!

Power BI User Groups are coming! Make sure you’re among the first to know when user groups go live for public preview.

March Update

Check it Out!

Click here to read more about the March 2021 Updates!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.