cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
po
Post Prodigy
Post Prodigy

Possible to ensure button always stays on top of a visual/line chart

Hi,

 

Have line chart below with drill through button which works when select point on line chart.

 

Ideally woudl like thsi button to be on top of the chart i.e. within the white border (i.e. top right) 

 

Have used align bring to front and visible when not selecting an individual point to drillthrough.  When do then the button disappears presumably as focus on the line chart which being selected.

 

Is it possible to have the green button below always on top of the line chat visible?

 

Don;t want to have to have another white rectangle below just to give impression part of same chart - woudl just wnat to place it on top of the chart e.g top right so always vsisible.

 

button.JPG

 

Thanks

 

1 ACCEPTED SOLUTION

@po 

Yes, you may need to do the same with the actual visual, but "send it to the back" and then set maintain layer order

EDIT: Actually, if you format the actual visual by sending it to the back and enabling the option "maintain layer order" (so no need to format the button), it works.

2021-03-05.png

 

Bookmarks and buttons.gif

 





Did I answer your question? Mark my post as a solution!
In doing so, you are also helping me. Thank you!

Proud to be a Super User!
Paul on Linkedin.






View solution in original post

13 REPLIES 13
Pragati11
Super User
Super User

Hi @po ,

 

Can you share the BACKGROUND settings for your chart?

I think if you click on your visual and go to format option then switch off BAckground: (as shown below)

Pragati11_0-1614872201028.png

Now place your button on top of your visual and do BRING to FRONT. This should resolve your issue.

 

Let me know how you get along with this.

 

Thanks,

Pragati


My Blog: Data Vibe
Connect: LinkedIn
Connect: Twitter






If this helps, Appreciate a KUDOS!
Did I answer your question? Mark my post as a solution!


Proud to be a Super User!




Hi Pragati,

 

Thanks for reply.

 

Have background set to on for line chart visual.

 

Resaon have set to on is to have white background for visual.

 

If set background to off button contibues to be visible and solve this.

 

However, ideally woudl like to have background on and still have button visible.

 

Reason looking to have white background is due to company image in background makes the chart stand out less as opposed to white backgroudn of vsiual.

background_set_to_off.JPG

 

Is it possible to have the white background on the chart and the button still visible somehow?

 

Thanks

@po 

To keep the button at the front, "bring it to the front" as @Pragati11  suggests and turn on the "Maintain layer order" under the "General" formatting settings for the button in the formatting pane.

Captura.JPG

 

Just beware that this setting will only apply once the report is published; it has no effect while editing on Desktop. 

This way, in the published report, the button will always be placed on top of the visual.





Did I answer your question? Mark my post as a solution!
In doing so, you are also helping me. Thank you!

Proud to be a Super User!
Paul on Linkedin.






Hi @PaulDBrown ,

 

Thanks for sharing this workaround. I learnt something new today. 🙂

 

Thanks,

Pragati


My Blog: Data Vibe
Connect: LinkedIn
Connect: Twitter






If this helps, Appreciate a KUDOS!
Did I answer your question? Mark my post as a solution!


Proud to be a Super User!




Hi @po ,

 

What happens if you set Background = ON for both visual and button?

 

Thanks,

Pragati


My Blog: Data Vibe
Connect: LinkedIn
Connect: Twitter






If this helps, Appreciate a KUDOS!
Did I answer your question? Mark my post as a solution!


Proud to be a Super User!




Hi,

 

When background set to ON for both button not visible when place on top of chart.

 

Thanks

Did you set button to BRING To FRONT after swiching on background?


My Blog: Data Vibe
Connect: LinkedIn
Connect: Twitter






If this helps, Appreciate a KUDOS!
Did I answer your question? Mark my post as a solution!


Proud to be a Super User!




Hi,

 

Thanks for reply.

 

Yes tried that.

 

What looks to happen is that when click on data point on chart visual, the button disappears 

 

Then if click elsewhere on the report e.g. another visual the button reappears.

 

Ideal user workflow  woudl be for user to click point on chart, button stays visible then can click.  Wouldn't want ideally to have to say to users if clcik point in chart, then need to add extra step of clicking another visual to see button as not user-friendly and would be 3 rather than 2 mouse-clicks.

 

Thanks

Hi @po ,

 

Yeah that's what I suspected as you are using point click finctionality to enable your button. Generally in these scenarios we keep BUTTON at the bottom of the chart but in your case you want it over thet chart. I can only suggest setting background OFF for your visual.

Not sure if you can share your pbix file so that I can have a go by removing any sensitive information.

Use dropbox to create downlaodable link to your pbix file.

 

Thanks,

Pragati


My Blog: Data Vibe
Connect: LinkedIn
Connect: Twitter






If this helps, Appreciate a KUDOS!
Did I answer your question? Mark my post as a solution!


Proud to be a Super User!




Hi,

 

Thanks for reply.

 

Unfortuanetly can't share due to nature of data.

 

workaround I'm uisng is button at bottom but this inside a white rectangle rather than part of chart to give illusion part of chart.

 

When you have your button at bottom of chart is it part of actual chart visual itself?

If could have as part of chart visual even at bottom that would be improvement on what currently doing with separate white rectangle to house the button.

 

 

button1.JPG

 

po
Post Prodigy
Post Prodigy

Hi both,

 

Tried suggestion of setting maintina layer order on button itself, republished to service and still same behaviour button disappears.

 

Do we also need to set maintian layer order onthe chart visual?

 

Do you hane an exampel of a working .pbx with this backgroudn set on both with button visible on top of chart.

Thanks

@po 

Yes, you may need to do the same with the actual visual, but "send it to the back" and then set maintain layer order

EDIT: Actually, if you format the actual visual by sending it to the back and enabling the option "maintain layer order" (so no need to format the button), it works.

2021-03-05.png

 

Bookmarks and buttons.gif

 





Did I answer your question? Mark my post as a solution!
In doing so, you are also helping me. Thank you!

Proud to be a Super User!
Paul on Linkedin.






View solution in original post

Hi,

 

Thanks both for your help on this.

 

Set send to back and maintian layer order on line chart visual itself and now works as expected with button persisting in foreground.

 

Thanks

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.