cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Pivot column - Dont aggregate

Hi,

 

i've got these three columns like in the attach.

Column two needs to be transformed into Pivot Column, but I get error when doing so.

 

There was a topic here and a guy said it all columns should be promoted as text, didnt solve it though, or I didnt understand him.

 

Regards

 

Capture.JPG

1 ACCEPTED SOLUTION

Accepted Solutions

thanks for the hints.

 

the solution is withing this video (although he uses two columns only, it works with a third).

 

https://www.youtube.com/watch?v=B9_jHZrmkHo

View solution in original post

2 REPLIES 2
Community Champion
Community Champion

Only the Pivot column needs to be text; however if you use the menu-option to pivot on a non-text column, the generated code will take care of the transformation to text. Then again: it is not the most nice-looking code, so I would recommend to transform the pivot column to text before pivoting.

 

You have duplicates. This is not allowed with option "Don't aggregate".

Specializing in Power Query Formula Language (M)

thanks for the hints.

 

the solution is withing this video (although he uses two columns only, it works with a third).

 

https://www.youtube.com/watch?v=B9_jHZrmkHo

View solution in original post

Helpful resources

Announcements
November Update

Check it Out!

Click here to read more about the November 2020 Updates!

Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

secondImage

Power Platform October Community Highlights

Check out the top community contributors across all of the communities

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors
Top Kudoed Authors