cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Solution Sage
Solution Sage

Permission is required to run this native database query

hey All,

I woke up this morning to this.

2019-07-29 11_56_29-papercut - Remote Desktop Connection.png

Why? How can I resolve this? How can avoid it in the future?
Cheers!
A

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User IV
Super User IV

Re: Permission is required to run this native database query

In PowerBI desktop go to

  • Home > Edit Queries.
  • File > Options and Settings > Options
  • Security > uncheck "Require user approval for new native database queries"

If this is checked and someone else save the .pbix, when you open it you will be required to give your approval again.

TurnOffnativeQuery.jpg

View solution in original post

1 REPLY 1
Highlighted
Super User IV
Super User IV

Re: Permission is required to run this native database query

In PowerBI desktop go to

  • Home > Edit Queries.
  • File > Options and Settings > Options
  • Security > uncheck "Require user approval for new native database queries"

If this is checked and someone else save the .pbix, when you open it you will be required to give your approval again.

TurnOffnativeQuery.jpg

View solution in original post

Helpful resources

Announcements
August 2020 Community Challenge: Can You Solve These?

August 2020 Community Challenge: Can You Solve These?

We're excited to announce our first cross-community 'Can You Solve These?' challenge!

Community Blog

Community Blog

Visit our Community Blog for articles, guides, and information created by fellow community members.

Upcoming Events

Upcoming Events

Wondering what events you could join or have an event to promote yourself? Check out our Upcoming Events.

Community Summit Australia – Join Online!

Community Summit Australia – Join Online!

Be a part of the leading Microsoft Business Applications digital event, curated for the APAC community.

Top Solution Authors
Top Kudoed Authors