cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
creynolds Member
Member

Percentage Value Not Showing Correctly

I have the following table along with the two columns which are used to calculate percentages using the values in this table.   For some reason, the percentages are not showing up correctly.    Is there add'l formatting I need to do for the two percentage columns?

 

Capture.PNGTableCapture60.PNG% Completed 60 DaysCapture3.PNG% Complete in 14 Days

2 ACCEPTED SOLUTIONS

Accepted Solutions
v-danhe-msft Super Contributor
Super Contributor

Re: Percentage Value Not Showing Correctly

Hi @creynolds,

From your posted picture, it seemed that most of your columns are measures and I could not figure your data structure, could you please offer a sample data to have a test if possible?

 

Regards,

Daniel He

Community Support Team _ Daniel He
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

bhpage Member
Member

Re: Percentage Value Not Showing Correctly

It looks like you created these as new columns, rather than new measures. The percentage needs to be computed on aggregate, not for each row, and then aggregated - that's what's happening now. Try creating a new measure and using this: 

 

Completed in 14 Days % = SUM('Squirrel SQL Export'[TOTAL_COMPLETED]) / SUM('Squirrel SQL Export'[% COMPLETED IN 14 DAYS])
 
Same goes for the other % calc.
 
Ben

View solution in original post

4 REPLIES 4
v-danhe-msft Super Contributor
Super Contributor

Re: Percentage Value Not Showing Correctly

Hi @creynolds,

From your posted picture, it seemed that most of your columns are measures and I could not figure your data structure, could you please offer a sample data to have a test if possible?

 

Regards,

Daniel He

Community Support Team _ Daniel He
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

creynolds Member
Member

Re: Percentage Value Not Showing Correctly

I created a sample table with the same issue; here are the files:

 

Work Order XLS

Work Order PBIX

bhpage Member
Member

Re: Percentage Value Not Showing Correctly

It looks like you created these as new columns, rather than new measures. The percentage needs to be computed on aggregate, not for each row, and then aggregated - that's what's happening now. Try creating a new measure and using this: 

 

Completed in 14 Days % = SUM('Squirrel SQL Export'[TOTAL_COMPLETED]) / SUM('Squirrel SQL Export'[% COMPLETED IN 14 DAYS])
 
Same goes for the other % calc.
 
Ben

View solution in original post

creynolds Member
Member

Re: Percentage Value Not Showing Correctly

That worked!   Thanks.

Helpful resources

Announcements
Can You Solve These Challenge

Challenge: Can You Solve These?

Find out how to participate in the first Power BI 'Can You Solve These?' challenge.

Community News & Announcements

Community News & Announcements

Get your latest community news and announcements.

Virtual Launch Event

Microsoft Business Applications October Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

Community Kudopalooza

Win Power BI Swag with Community Kudopalooza!

Each week, complete activities and be qualified in the drawing for cool Power BI Swag.

Users Online
Currently online: 429 members 4,078 guests
Please welcome our newest community members: