cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
floressdiego
Helper I
Helper I

Parameter 4+ digits not working?

Hello,

I was trying to create a parameter in my dashboard but it wasn't working properly then I tried to circle the problem. Te thing is that when I typed a 4 digit parameter it just didn't show the number I typed in correctly. I tried to create a new dashboard, blank, nothing in it except the parameter and it still bugged.

 

Example: typed 1234

floressdiego_0-1632321797316.png

as soon as I press enter it changes.

Typed 123

floressdiego_1-1632321850012.png

changed again.

Typed 1245

floressdiego_2-1632321885819.png

and again..........

 

What I found out is that when it's less than 4 digits it works fine, above it it messes up almost everytime....

 

Why is that? Can't have precision with 10000 rows?

 

Just to be sure, all I did was create the parameter, as follows:

floressdiego_3-1632322048229.png

 

 

Thanks

 

Diego

1 ACCEPTED SOLUTION

It doesn't do for me because I want it as a password and I can't have a bar for 10000 numbers. What I found was that if I make it 5 digit then on the generated measure put MAX(Table[Column]) and on the slicer I put less or equal, it works just fine... 

 

Thanks for the help.

 

 

View solution in original post

5 REPLIES 5
v-xiaotang
Community Support
Community Support

Hi @floressdiego 

It's because of the range being too big and the numbers are being sampled. If you use Parameter = GENERATESERIES(0, 999, 1), it works fine.

To get around this behavior, you can use Slicer, or just drag the scrollbar to specific position.

I also find a similar post, please check if it can help, https://community.powerbi.com/t5/Desktop/What-if-parameter-help-input-changes-by-itself-after-hittin...

 

 

Best Regards,

Community Support Team _Tang

If this post helps, please consider Accept it as the solution to help the other members find it more quickly.

It doesn't do for me because I want it as a password and I can't have a bar for 10000 numbers. What I found was that if I make it 5 digit then on the generated measure put MAX(Table[Column]) and on the slicer I put less or equal, it works just fine... 

 

Thanks for the help.

 

 

Hi @floressdiego 

Thanks for your reply. 

Yes, if you use less or equal, it works fine. but if you use single value, the numbers will be sampled.

-

could you kindly accept the answer helpful as the solution. so the others can find it more quickly.
really appreciate!

 

Best Regards,
Community Support Team _Tang

amitchandak
Super User
Super User

@floressdiego , click on that I sign and check what is that showing?

floressdiego_0-1632334355684.png

"Excess of values for 'Parâmetro'. Only showing representative example. Filter data or select another field."

 

 

So it does have a maximum range of values to be exact... 

 

It doesn't help me though....... Is there a way to make the range bigger? 

Helpful resources

Announcements
Carousel_PBI_Wave1

2023 Release Wave 1 Plans

Power BI release plans for 2023 release wave 1 describes all new features releasing from April 2023 through September 2023.

Power BI Summit Carousel 2

Global Power BI Training

Make sure you register today for the Power BI Summit 2023. Don't miss all of the great sessions and speakers!

BizApps LATAM 2023

Business Application LATAM Summit 2023

Join the biggest FREE Business Applications Event in LATAM this February.

Power Platform Bootcamp

Global Power Platform Bootcamp

In this bootcamp we will deep-dive into Microsoft’s Power Platform stack with hands-on sessions and labs, delivered to you by experts and community leaders.