cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
danielPrieto
Advocate I
Advocate I

Option "Concatenate labels" of X-Axis in column chart not works

In the last version of PowerBI Desktop (June 2018) not works the option "Concatenate labels" of X-Axis in column chart when we drill down to the lowest level of the hierarchy. I try this same functionallity on a previous version (February 2018) and works fine.

5 REPLIES 5
v-qiuyu-msft
Community Support
Community Support

Hi @danielPrieto,

 

You need to set the chart sort by the X axis columns, see: 

 

q2.PNG

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hello,

 

Do you do something special to have the vertical lines that separate the X labels ? I don't have it separated when I use concatenate label. My 2 labels are in the same line. How can I put one label per line ?

 

Thank you,

 

DM

Hi @v-qiuyu-msft

 

Thanks for yout reply by I'm in the same situation. I sort by X axis and desactive "Concatenate Labels" option of X-axis. See screenshot below:

 

errorConcatenateLabels.png

 

Regards,

Daniel

Hi @danielPrieto,

 

Please update the Power BI desktop to the latest version then test again. 

 

If issue persists, please share the pbix file with us. 

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Version: 2.59.5135.421 64-bit (june 2018) PBI Desktop

 

Having similar issues. I have 2 datasets that are not linked in a report. In both I created some extra date columns from a date (Year, Quarter, Month & week). In 1 dataset I somehow got the concatenate labels off eventually, though not entirely sure how. In a stacked column I had Year, Quarter, Month & Week and it works. 

 

Then the other dataset same thing, created the columns in the same way. Then again a stacked column with same order as above. Doesn't work, allways get them all lined up in 1 string. Then I removed it just dropped the date column on the x-axis and let PBI create a date hierarchy automatically. Now it does work, but the month are strings rather than number, I wanted quarter formatted as Q1,Q2 etc and week rather than day. 

 

Then I tried it again with the derived columns. And they got instantly concatenated again. And yes the visual is set sorted by x-axis. I did notice that it did not work when choosing drill all down 1 level, but when turning on drill down and selecting 1 column it did work properly. 

 

Then I toggled the sorting to y-axis and back to x-axis, now it works, but it only gives me the reverse order as option. (as in Q2 on left, Q1 on right. I'd show images but the data is sensitive. It seems to me that at allthough the feature sort of works, getting it to work with own variables rather than automatic date hierarchy is at least more frustratring/less robust then it needs to be. Wouldn't turning it off by default not be more logical anyway. Who likes reading those repeated, tilted & long labels when you can have it nicely grouped together

 

 

Helpful resources

Announcements
User Groups Public Preview

Join us for our User Group Public Preview!

Power BI User Groups are coming! Make sure you’re among the first to know when user groups go live for public preview.

March Update

Check it Out!

Click here to read more about the March 2021 Updates!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.