cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Tonil
New Member

Odata context URL is invalid

When trying to Get Data from an Odata source, from Dynamics 365 Business Central Online, I get the below error, yet other Odata links from the same database connect fine. We are looking at Vendor data but in the Item Ledger Entry (ILE) table, and the link works fine in the browser, but not when trying to load into PBI.

 

image.png

image.pngimage.png

We have filtered the query to reduce the data, so the issue is not size, we have recreated the Query, republished the query, reduced the number of columns, and each scenario populates the data in the browser window, however it won’t load into PBI.

We have opened a new file in PBI, connected to an existing odata source which works fine, but this new one linking to Item Ledger entries in Business Central is not.

The webservices that work and that don’t work are created in a similar way in the Business Central extension through a query object. The browser is using the same connection method with username and webserviceaccesskey and we use the same username details in PBi. We have compared the first part of the URL results for the file that would load (ITEMSACPBI) and the file that won’t (VILE2), and they are identical. {"@odata.context":"https://api.businesscentral.dynamics.com/v2.0/ ODataV4/$metadata#Company('My%20Company')/ITEMSACPBI","value" {"@odata.context":"https://api.businesscentral.dynamics.com/v2.0/ ODataV4/$metadata#Company('My%20Company')/VILE2","value"

Any ideas/help would be appreciated! Thanks

3 REPLIES 3
j2associates
New Member

This makes no sense to me, but it worked. I was getting the exact same error as others have posted above for a query that was setup identically to other queries that were working. To resolve the issue, I cleared all Cache and User Permissions within the Power BI desktop. After doing so, the query then pulled data as expected.

 

amitchandak
Super User IV
Super User IV
Greg_Deckler
Super User IV
Super User IV

@Tonil - Tough to say exactly. You could check the Issues forum here:

https://community.powerbi.com/t5/Issues/idb-p/Issues

And if it is not there, then you could post it.

If you have Pro account you could try to open a support ticket. If you have a Pro account it is free. Go to https://support.powerbi.com. Scroll down and click "CREATE SUPPORT TICKET".


---------------------------------------

@ me in replies or I'll lose your thread!!!

I have a NEW book! 
DAX Cookbook from Packt
Over 120 DAX Recipes!




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!




Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are You Ready?

Test your skills now with the Cloud Skills Challenge.

Top Solution Authors