cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
hhuddleston
Advocate I
Advocate I

Number Formatting on Card Visualization

I have a card visualization that totals the number of ticket scans for a tourist attraction. This is a direct query dataset, so it is essentially giving real time data, updated every minute. The number in the dataset is an int data type and I have set it as a comma seperated whole number in the Modelling tab, and the format is also set as a whole number.  In the card format for Data Label Display units is set to None. The issue is that is displays properly as a comma seperated number up until it reaches 10,000, but then the display switches to 10.1 K instead of 10,100 (or 10,125) which is how I want it to display. The attraction manager wants it to show it as a comma seperated number no matter how high the number goes. Any help would be appreciated.

1 ACCEPTED SOLUTION

I managed to get this to display properly, using the following settings:

 

Data Modeling in PBI model

  • Data Type - Whole Number
  • Format - Whole Number
  • Thousands Seperator - Enabled
  • Decimal Places - 0

Visualization for Card

  • Display Units - None

Thanks for everyone's input!

 

Herb

View solution in original post

7 REPLIES 7
v-huizhn-msft
Microsoft
Microsoft

Hi @hhuddleston,

I import data in direct query mode, and add the date into  a card, it also shows correctly, please see the following screenshot.

1.PNG

Best Regards,
Angelia

Interkoubess
Solution Sage
Solution Sage

Hi @hhuddleston,

 

It is weird, I tried as you explained and I have this visual.

Can you please show us a sample in order to better understand your request.

 

Thank you,

 

Data_format.PNG

The card on the left is what I want to display - no matter how high the number goes.

The card on the right is what happens when it crosses the 10,000 mark.

 

Total Scans Examples.PNG

Hi @hhuddleston,

 

Either you give us your sample in order to test it again, but I still have the right visual ( on the left) when I tested on my computer.

Perhaps another person can elaborate the issue ( if it is )....

Thank you

I managed to get this to display properly, using the following settings:

 

Data Modeling in PBI model

  • Data Type - Whole Number
  • Format - Whole Number
  • Thousands Seperator - Enabled
  • Decimal Places - 0

Visualization for Card

  • Display Units - None

Thanks for everyone's input!

 

Herb

View solution in original post

It works. Thank you!

Modeling Ribbon > New Column

Count = 1

Drag the Card Visual to the Report Canvas

Drag the new Count column from the Fields area to the Card Visual

 

Modeling Ribbon 

  • Data Type - Whole Number
  • Format - Whole Number
  • Thousands Seperator - Enabled
  • Decimal Places - 0

Visualization for Card > Format Roller

  • Display Units - None

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are You Ready?

Test your skills now with the Cloud Skills Challenge.

Top Solution Authors