cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Not reporting blank data when i use x axis with Quarterly date.

Hi

 

I am not getting all the data when i am using quarterly date on X axis

 

visual is coming with skipping the value which is not having the data and reporting with valued data.

 

I need to report in line chart with blank as zero for that quarterly.

 

i am using the condition as below when i select male & female some of the values are reporting properly but some not.

 

text= IF(OR(ISBLANK(table[column]),table[column]=0),"MALE","FEMALE")
 
Let me know if i need to add anything.
 
before that i have applied for that particular column with show item with no data also. but no luck.
 
i want to report all the quarterly data with 0 even it is blank without skip of that particular quarter.
 
Please suggest.
1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Not reporting blank data when i use x axis with Quarterly date.

@rajendraongole1 ,

 

Modify the measure:

result =
IF (
    ISBLANK ( tablename[column] )
        || tablename[column] = 0
        || tablename[column] = null,
    "MALE",
    "FEMALE"
)

Community Support Team _ Jimmy Tao

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
Community Support Team
Community Support Team

Re: Not reporting blank data when i use x axis with Quarterly date.

@rajendraongole1 ,

 

Modify the calculate column using dax below:

text =
IF (
    ISBLANK ( table[column] )
        || table[column] = 0
        || table[column] = "",
    "MALE",
    "FEMALE"
)

Community Support Team _ Jimmy Tao

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Highlighted

Re: Not reporting blank data when i use x axis with Quarterly date.

Hi 

 

As per attached chart., is there any way to report missed data points in line chart with "0" tried with show items with no data option for x axis. but not coming. Let know is there any way?

 

imag.png?

Re: Not reporting blank data when i use x axis with Quarterly date.

 

Thanks for the response..

 

I have written calculated column as below:

 

tablename[column] is numeric data.

 

IF(ISBLANK(tablename[column])||tablename[column] = 0 || tablename[column] = "","MALE","FEMALE")
 
in the above,facing err like integer value comparing with string which is not accepting it as new column. 
 
Any suggestions
Community Support Team
Community Support Team

Re: Not reporting blank data when i use x axis with Quarterly date.

@rajendraongole1 ,

 

Modify the measure:

result =
IF (
    ISBLANK ( tablename[column] )
        || tablename[column] = 0
        || tablename[column] = null,
    "MALE",
    "FEMALE"
)

Community Support Team _ Jimmy Tao

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
New Kudos Received Badges Coming

New Kudos Received Badges Coming

Kudos to you if you earned one of these! Check your inbox for a notification.

Microsoft Implementation for Communities Wins Award

Microsoft Implementation for Communities Wins Award

Learn about the award-winning innovation that was implemented across Microsoft’s Business Applications Communities.

Power Platform World Tour

Power Platform World Tour

Find out where you can attend!

Top Kudoed Authors (Last 30 Days)
Users online (2,492)