cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dyingod Frequent Visitor
Frequent Visitor

Newbie baby-steps question

Hello!

 

My company just decided to switch to Power BI for all reporting and I've been watching the tutorials religiously but I'm obviously doing something wrong... can anyone with patience help? This is definitely a stupidly obvious thing I'm missing because my Power BI experience is only 10 minutes old.

 

Why don't dates show up properly here if my relationships SEEM to be all good? I've left the date hierarchy in so that you see that DimDate is formatted as a date (I can confirm that so is the Date column in my FactTable). But the issue is just that I expected Cost to be broken down by date and yet date is empty ("Year" in this case). Thanks in advance! Smiley Embarassed

 

dashboard.PNGrelationships.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
Super User
Super User

Re: Newbie baby-steps question

You should only create Dimension tables if the dimensions have 3+ columns. In your case the dimension tables only have a single column, so there is no reason to have these at all. Just load the single flat table. 

 

Re your problem, are you sure the relationship a created properly?



* Matt is a Microsoft MVP (Power BI) and author of the Power BI Book Supercharge Power BI.
2 REPLIES 2
Super User
Super User

Re: Newbie baby-steps question

You should only create Dimension tables if the dimensions have 3+ columns. In your case the dimension tables only have a single column, so there is no reason to have these at all. Just load the single flat table. 

 

Re your problem, are you sure the relationship a created properly?



* Matt is a Microsoft MVP (Power BI) and author of the Power BI Book Supercharge Power BI.
Highlighted
dyingod Frequent Visitor
Frequent Visitor

Re: Newbie baby-steps question

Hey Matt,

 

Thanks for this! After a few hours mucking around I've found the answer to the question... and it's a super noob one... my FactTable date wasn't formatted as a date even though my Dimension table data was. Once that was rectified, it was smooth sailing then.

 

Thanks again for your help. I just wanted to fix the issue for the sake of learning but I will follow your advice and just query straight from fact table. Cheers