cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
KLJ
Helper I
Helper I

Need help with R script

Hi

 

I have two tables in my report. In query editor I have merged them and then I want to save the result to a text file.

 

I have tried to add this script to the query Itemlist:


require(gdata)
write.table(trim(dataset), file="C:/Users/KLJ/Documents/Power BI/Test10.txt", sep = "\t", row.names = FALSE, append = TRUE)
plot(dataset);

 

but I get this message:

Capture.JPG

(Sorry for the bad picture)

 

Is there a R script that can save this query to a text file?

R scrips is very new to me. 

 

Here is a link to a copy of the pbix file

 

Thanks in advance.

 

Best regards 

Kim

1 ACCEPTED SOLUTION
5 REPLIES 5
stretcharm
Memorable Member
Memorable Member

I've used R to export data a few times from both ther editor and the visuals

 

This R script works for me.

 

# 'dataset' holds the input data for this script

write.table(dataset, file="C:\\temp\\Test.txt", sep = "\t", row.names = FALSE, append = TRUE)

output <- dataset

The M for my test looks like this.

 

    Source = Table.NestedJoin(Table2,{"Column1"},Table2,{"Column1"},"Table2",JoinKind.LeftOuter),
    #"Expanded Table2" = Table.ExpandTableColumn(Source, "Table2", {"Column2", "Column3"}, {"Table2.Column2", "Table2.Column3"}),
    #"Run R Script" = R.Execute("# 'dataset' holds the input data for this script#(lf)#(lf)write.table(dataset, file=""C:\\temp\\Test.txt"", sep = ""\t"", row.names = FALSE, append = TRUE)#(lf)#(lf)output <- dataset",[dataset=#"Expanded Table2"]),
    #"""output""" = #"Run R Script"{[Name="output"]}[Value]
in
    #"""output"""

Trim in r doesn't work on a dataframe. So if you need to trim either do it before you export in M or use sapply functions in r.

M is easiest, but the R option might be quicker with very large datasets.

Hi stretcharm

 

I've tried your proposal but I still get the same error message.

 

 

 

 

I rebuild the query according to @KenPuls blog but still got the error.

Then I changed the the Privacy for the file to Ignore the privacy levels and it worked.

I not sure that is the right way to do this but ontil there is another solution this most do it for now.

 

Thank for your help @stretcharm

So turning off Privacy does a couple of things:

  • It will ignore the error
  • It will (most likely) speed up performance

The issue is that it no longer checks to make sure the data sources are safe to combine without leaking data.  If all my data is in the organization, I usually turn this setting off, but you do want to be careful of just doing that as a blanket answer.

Helpful resources

Announcements
Carousel_PBI_Wave1

2023 Release Wave 1 Plans

Power BI release plans for 2023 release wave 1 describes all new features releasing from April 2023 through September 2023.

Power BI Summit Carousel 2

Global Power BI Training

Make sure you register today for the Power BI Summit 2023. Don't miss all of the great sessions and speakers!

BizApps LATAM 2023

Business Application LATAM Summit 2023

Join the biggest FREE Business Applications Event in LATAM this February.

Power Platform Bootcamp

Global Power Platform Bootcamp

In this bootcamp we will deep-dive into Microsoft’s Power Platform stack with hands-on sessions and labs, delivered to you by experts and community leaders.