cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
payelsaha1709 Frequent Visitor
Frequent Visitor

NaN value is coming

Hi,

 

When i'm publishing the report and accessing from workspace, all the data are coming properly. And this published report is working properly since more than 2 weeks. But suddenly one morning noticed that 'NaN' is coming in one of the Matrix in all the value fields. After re-publishing the report proper data is coming for that day, but in the next day morning again 'NaN' is coming in that Matrix. The dataset for that report get schedule refreshed at 12:00 AM.

Please let mw know how to overcome this issue.

 

Thanks,

Payel

1 ACCEPTED SOLUTION

Accepted Solutions
payelsaha1709 Frequent Visitor
Frequent Visitor

Re: NaN value is coming

Hi Xiaoxin,

 

Thanks for the reply.

Hopefully i'm able to short out the issue. Database table data population job and report dataset refresh job was executing at the same time and seems due to this the report dataset was getting 0 value for all the objects. So after calculation, 0 devide by 0 was coming as NaN. I have changed the power bi report dataset schedule refresh time and did not get that issue any more in last three days.

 

Thanks,

Payel

2 REPLIES 2
Community Support Team
Community Support Team

Re: NaN value is coming

Hi @payelsaha1709,

 

I can't reproduce your issue, can you please share us some detail content to clarify your scenario?

 

Please refer to below link to share more useful information for troubleshooting.

Troubleshooting the on-premises data gateway

 

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin Sheng
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.



For learning resources/Release notes, please visit: | |
payelsaha1709 Frequent Visitor
Frequent Visitor

Re: NaN value is coming

Hi Xiaoxin,

 

Thanks for the reply.

Hopefully i'm able to short out the issue. Database table data population job and report dataset refresh job was executing at the same time and seems due to this the report dataset was getting 0 value for all the objects. So after calculation, 0 devide by 0 was coming as NaN. I have changed the power bi report dataset schedule refresh time and did not get that issue any more in last three days.

 

Thanks,

Payel

Helpful resources

Announcements
Community Kudopalooza

Win Power BI Swag with Community Kudopalooza!

Each week, complete activities and be qualified in the drawing for cool Power BI Swag.

Summit North America

Power Platform Summit North America

Register by September 5 to save $200

Virtual Launch Event

Microsoft Business Applications Virtual Launch Event

Watch the event on demand for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

MBAS Gallery

Watch Sessions On Demand!

Continue your learning in our online communities.

Users Online
Currently online: 125 members 1,714 guests