cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
elaine_dunwoody
Regular Visitor

Model takes long time to open in Power BI Desktop

Hi, 

 

I'm PBI file is only 1MB in size, and the model is in Star Schema. It has data in import mode (from Excel sheets). I have checked that the visuals on the first page do not take long to load. However, each time I open the file in Power BI Desktop, it takes a long time (over 10 mins). (My machine has 16 GB Ram.) Which area should I look at to improve the performance? 

 

Regards,

Elaine

2 ACCEPTED SOLUTIONS
amitchandak
Super User IV
Super User IV

@elaine_dunwoody , In file option and setting -> Option -> Under Data load, increase Data Cache and management option.

It might 4 GB, Inrease that and check



Did I answer your question? Mark my post as a solution! Appreciate your Kudos!!
Dashboard of My Blogs !! YouTube Channel !! Connect on Linkedin

Proud to be a Super User!

View solution in original post

TomMartens
Super User II
Super User II

Hey @elaine_dunwoody ,

 

in addition to what @amitchandak already pointed out, it seems odd that you have to wait 10min until a 1MB pbix is opened.

Nevertheless, there are certain things happening if you open the file:

  • the dataset is loaded from your drive into the memory
  • data is queried by the visuals

The picture below shows what has happened after a ~262 was opened using PBI desktop:

image.png

The red rectangle shows that ~262MB has been "expanded" to 2.8GB.

 

This is ~1GB of the dataset, ~750MB by PBI Desktop, and some visuals, these visuals are represented by the CefSharp.BrowserSubprocess.

 

This means that it's hard to guess the time to open and RAM consumption from the physical file size.

The above-mentioned file opens in ~40sec on my machine (thinkpadx13 gen1, i7, 16GB of RAM). 

 

I recommend adding an empty page and make this page the active page, close the file, and reopen. Then watch the task manager, you will see the processes that take time.

 

My assumption is that you are using some calculated columns, it's always a good idea to use Power Query to create these columns, this of course will not shorten the time if a data refresh is happening, but should shorten the time if you "just" open the pbix.

 

Without the pbix, it's difficult to say what's eating up the time.

 

Hopefully, this provides some ideas on how to tackle your issue.

 

Regards,

Tom



Did I answer your question? Mark my post as a solution, this will help others!

Proud to be a Super User!
I accept Kudos 😉
Hamburg, Germany

View solution in original post

2 REPLIES 2
TomMartens
Super User II
Super User II

Hey @elaine_dunwoody ,

 

in addition to what @amitchandak already pointed out, it seems odd that you have to wait 10min until a 1MB pbix is opened.

Nevertheless, there are certain things happening if you open the file:

  • the dataset is loaded from your drive into the memory
  • data is queried by the visuals

The picture below shows what has happened after a ~262 was opened using PBI desktop:

image.png

The red rectangle shows that ~262MB has been "expanded" to 2.8GB.

 

This is ~1GB of the dataset, ~750MB by PBI Desktop, and some visuals, these visuals are represented by the CefSharp.BrowserSubprocess.

 

This means that it's hard to guess the time to open and RAM consumption from the physical file size.

The above-mentioned file opens in ~40sec on my machine (thinkpadx13 gen1, i7, 16GB of RAM). 

 

I recommend adding an empty page and make this page the active page, close the file, and reopen. Then watch the task manager, you will see the processes that take time.

 

My assumption is that you are using some calculated columns, it's always a good idea to use Power Query to create these columns, this of course will not shorten the time if a data refresh is happening, but should shorten the time if you "just" open the pbix.

 

Without the pbix, it's difficult to say what's eating up the time.

 

Hopefully, this provides some ideas on how to tackle your issue.

 

Regards,

Tom



Did I answer your question? Mark my post as a solution, this will help others!

Proud to be a Super User!
I accept Kudos 😉
Hamburg, Germany

View solution in original post

amitchandak
Super User IV
Super User IV

@elaine_dunwoody , In file option and setting -> Option -> Under Data load, increase Data Cache and management option.

It might 4 GB, Inrease that and check



Did I answer your question? Mark my post as a solution! Appreciate your Kudos!!
Dashboard of My Blogs !! YouTube Channel !! Connect on Linkedin

Proud to be a Super User!

View solution in original post

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Get Ready for Power BI Dev Camp

Power BI Dev Camp - June 24th

Mark your calendars and join us for our next Power BI Dev Camp!

Top Solution Authors
Top Kudoed Authors