cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Post Partisan
Post Partisan

Missing data after refresh

Hi there. Why would certain data (always only from two columns) disappear in the reports after refreshing it in PowerBI service. After uploading pbix files from OneDrive (tried Teams as well) and configuring gateway, the data is there and the reports look like they should. Once I refresh it manually or via scheduled refresh the data is gone and it never reappears. 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Post Partisan
Post Partisan

Re: Missing data after refresh

Problem solved. Turns out an account that was used to access the database and configure gateway didn't have full access to this database. So I changed it to my personal account and it worked. 

View solution in original post

5 REPLIES 5
Highlighted
Super User IX
Super User IX

Re: Missing data after refresh

@Alex_0201 ,

Once you upload open data connection setting in service make sure credentials are correct

 

Screenshot 2020-08-05 13.24.55.png

https://docs.microsoft.com/en-us/power-bi/connect-data/desktop-use-onedrive-business-links



Did I answer your question? Mark my post as a solution! Appreciate your Kudos!!
Dashboard of My Blogs !! YouTube Channel !! Connect on Linkedin

Proud to be a Super User!

Highlighted
Post Partisan
Post Partisan

Re: Missing data after refresh

Hi @amitchandak thanks! Credentials for all sources seem ok.

Capture.PNG

Highlighted
Community Support
Community Support

Re: Missing data after refresh

@Alex_0201 
Where is your datasources? I see you have pbix in onedrive, does the data source file also there?. If the data sources is online for example onedrive, you do not need a gateway to refresh. 


For the issue, I wonder what do you mean by data disappear, the data form datasource didn't refresh to the dataset on service or just the value is hidden in the report visual?

 

Regards

Paul Zheng _ Community Support Team

 

 

Highlighted
Post Partisan
Post Partisan

Re: Missing data after refresh

Hi @V-pazhen-msft it's an sql db. I suspect it could be due to a service account (not my personal account) used for setting up the gateway. 

I say disappear because once the reporst are refreshed, this data is not displayed anymore. And if I downlad this altered pbix to the desktop and open it, this data is still missing in the report.

Highlighted
Post Partisan
Post Partisan

Re: Missing data after refresh

Problem solved. Turns out an account that was used to access the database and configure gateway didn't have full access to this database. So I changed it to my personal account and it worked. 

View solution in original post

Helpful resources

Announcements
Ignite

Microsoft Ignite

This will be a conference that you do not want to miss!

Get Ready for Power BI Dev Camp

Get Ready for Power BI Dev Camp

Don't miss the Power BI Dev Camp this week!

August Community Highlights

Check out a full recap of the month!

August 2020 CYST Challenge

Check out the winners of the recent 'Can You Solve These?' community challenge!

Experience what’s next for Power BI

Join us for an in-depth look at the new Power BI features and capabilities at the free Microsoft Business Applications Launch Event.

Top Solution Authors