cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate II
Advocate II

Matrix Preview - Disable Drill-Down when using several fields as rows

Hello,

 

I really love the new Matrix Preview feature as it lets me filter my other visuals by clicking on a row in that matrix.

 

When I add several fields as rows, it will only let me use the drill-down functionality. I need the fields I added to the rows showing next to each other.

 

Is there any way to disable the drill-down functionality?

 

As a work-around I created a column concatenating the fields I need to show in a row, but it is bad for readabilty.

 

Thank you!

 

- Frank

5 REPLIES 5
Highlighted
Advocate II
Advocate II

Re: Matrix Preview - Disable Drill-Down when using several fields as rows

Go into the Format menu on the visual and disable "Stepped Layout" under the Row headers menu. Then go to your First row header/or conten under the first row header and "expand to next level" until you get your desired row headers. 

Highlighted
Microsoft
Microsoft

Re: Matrix Preview - Disable Drill-Down when using several fields as rows

Hi @ferzfeld,

Have you resolved your problem? As I tested, you can use "Stepped Layout" option to set a hierarchy beneath as @dsynan posted. More details, please review this article.

If you have other issues, please feel free to ask.

Best Regards,
Angelia



Highlighted
Advocate II
Advocate II

Re: Matrix Preview - Disable Drill-Down when using several fields as rows

Hi dsynan,

 

Thank you for your feedback. Expanding to the next level is getting me closer to the desired result, but still not providing the presentation of the data I need.

 

I created 2 screenshots to help understanding my problem:

 

1. Using the table visual which provides the correct presentation of the data (and correct sort-order). It does not provide the functionality to select a value and filter my visuals by this value.

 

07-04-2017 10-13-41.png

 

2. Using the matrix preview visual and expanding to the next level. The sort order of my rows is not as intended (grouped by OP)

 

07-04-2017 10-12-47.png

 

 This is probably the intended behaviour of the matrix visual, I am only using the visual because of the possibility to mark rows and use them as filter for my other visuals.

 

Thank you in advance!

- Frank

 

Highlighted
Microsoft
Microsoft

Re: Matrix Preview - Disable Drill-Down when using several fields as rows

Hi @ferzfeld,

As I tested, in Martrix preview, we are unable to achieve what you want. Thanks for understanding.

Best Regards,
Angelia

Highlighted
Helper I
Helper I

Re: Matrix Preview - Disable Drill-Down when using several fields as rows

THANK YOU!  

Helpful resources

Announcements
May 2020 Community Highlights

May 2020 Community Highlights

It’s time for another PBI Community recap!

Community Blog

Community Blog

Visit our Community Blog for articles, guides, and information created by fellow community members.

Using the Community

Using the Community

Need help with the Power BI Community? Our 'Using the Community' support articles are a great place to start.

Galleries

Galleries

Looking for inspiration on how to present your data? Need instructional videos? Check out our Galleries!

Top Solution Authors