cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper III
Helper III

Losing number formatting when I create a relation between tables.

This has been happening to me a few times. I tried googling but I can't find any result to why this is happening.

 

I have 3 tables: data, team and begroting.

Data is a list of employee's with a certain % score.

Team is a list of employees with a team number.

Begroting is a list that contains the budget per team number.

 

Data and Team are linked by employee number.

Team and begroting are linked by team number.

 

help.png

 

When I link the tables Team and Begroting together, all the number formatted columns lose their number formatting as illustrated below. When I want to use the columns from table begroting, I can't sum the values anymore.

 

1.PNG

 

Does anyone know why this is happening? Am I doing something wrong?

Any advice is welcome.

 

thanks!

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Microsoft
Microsoft

Re: Losing number formatting when I create a relation between tables.

Hi @ErikBI ,

 

Would you please check the summarize by option for these columns:

 

Capture.PNG

 

And please try to change it to sum.

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Best Regards,

Dedmon Dai

View solution in original post

3 REPLIES 3
Highlighted
Super User VII
Super User VII

Re: Losing number formatting when I create a relation between tables.

@ErikBI not sure why it is happening, usually it happens to the column that you are setting relation on but all other columns should stay as the aggregated columns. Can you put these columns in a visual and change the aggregation to sum?

 

I would  Kudos if my solution helped. 👉 If you can spend time posting the question, you can also make efforts to give Kudos whoever helped to solve your problem. It is a token of appreciation!

Visit us at https://perytus.com, your one-stop shop for Power BI related projects/training/consultancy.






Did I answer your question? Mark my post as a solution.

Proud to be a Super User! Appreciate your Kudos 🙂
Feel free to email me with any of your BI needs.





Highlighted
Microsoft
Microsoft

Re: Losing number formatting when I create a relation between tables.

Hi @ErikBI ,

 

Would you please check the summarize by option for these columns:

 

Capture.PNG

 

And please try to change it to sum.

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Best Regards,

Dedmon Dai

View solution in original post

Highlighted
Helper III
Helper III

de Re: Losing number formatting when I create a relation between tables.

Ah,, you made me realize that for some reason the column did not have the proper data type. 

 

Even though the ∑ signs are still not showing, I now have the option to sum the values, and it works! Thanks

Helpful resources

Announcements
Meet the 2020 Season 2 Power BI Super Users!

Meet the 2020 Season 2 Power BI Super Users!

Find out who's part of the program this season, and welcome the new Super Users.

August 2020 Community Challenge: Can You Solve These?

August 2020 Community Challenge: Can You Solve These?

We're excited to announce our first cross-community 'Can You Solve These?' challenge!

July 2020 Community Highlights

July 2020 Community Highlights

Learn about the exciting things that happened in July.

Featured Data Story of The Month

Featured Data Story of The Month

All Data Stories Gallery contributions are reviewed for each month. We select a contribution and feature the community member the following month.

Power BI Dev Camp - Developing with .NET Core

Power BI Dev Camp - Developing with .NET Core

Learn how to develop custom web applications for Power BI using .NET Core 3.1 and .NET 5.

Top Solution Authors
Top Kudoed Authors