cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jsimon Frequent Visitor
Frequent Visitor

Latest date in dataset not displaying on reports

Please forgive the newbie; hoping for a SIMPLE explanation...  I am having 'sudden' issues with my dashboard.  It seems that no matter what dataset I bring in, the displays are suddenly dropping the latest date.  For example, if the dataset contains data out to 5/3/2037, every records before this date is displayed, but having this date is being dropped.  This is consistent regardless of when the last date is, or how many records have this date...  they're all being dropped.  I was able further prove this out by simply adding a record with a date one month later, that was, as expected, dropped, while the one previously being dropped, was now included1.  Of course my first thought was the Page and/or Report filters (no Visual filters set), but for one thing, those do not have date parameters, only if not blank, which they're not.  The missing record(s) are included in the data query behind each page/pbix, just not displayed on the screen...  And it seems this JUST started happening after an update I did to my desktop (Version: 2.49.4831.521 64-bit (August, 2017)).  Is there some kind of built-in EOF I'm not aware of?  Perhaps having just a < and not <= ??  not too sure...  Another clue, when I publish the pbix (one taking a few mins to refresh) the correct amount is displayed while its refreshing, then is removed after that... (please see attached photo)  Many thanks in advance for any guidance or assistance on solving this!     2017-08-22 14_29_31-FW_ Dashboard issue - Message (HTML).png

 

 

6 REPLIES 6
Highlighted
jsimon Frequent Visitor
Frequent Visitor

Last date in dataset not displaying on reports

Please forgive the newbie; hoping for a SIMPLE explanation...  I am having 'sudden' issues with my dashboard.  It seems that no matter what dataset I bring in, the displays are suddenly dropping the latest date.  For example, if the dataset contains data out to 5/3/2037, every records before this date is displayed, but having this date is being dropped.  This is consistent regardless of when the last date is, or how many records have this date...  they're all being dropped.  I was able further prove this out by simply adding a record with a date one month later, that was, as expected, dropped, while the one previously being dropped, was now included1.  Of course my first thought was the Page and/or Report filters (no Visual filters set), but for one thing, those do not have date parameters, only if not blank, which they're not.  The missing record(s) are included in the data query behind each page/pbix, just not displayed on the screen...  And it seems this JUST started happening after an update I did to my desktop (Version: 2.49.4831.521 64-bit (August, 2017)).  Is there some kind of built-in EOF I'm not aware of?  Perhaps having just a < and not <= ??  not too sure...  Another clue, when I publish the pbix (one taking a few mins to refresh) the correct amount is displayed while its refreshing, then is removed after that... (please see attached photo)  Many thanks in advance for any guidance or assistance on solving this!       2017-08-22 14_29_31-FW_ Dashboard issue - Message (HTML).png

 

 

Ross73312 Super Contributor
Super Contributor

Re: Latest date in dataset not displaying on reports

What filters do you have on the report?  Could you have set some sort of flag or filter that the newer dates fall foul of?


   

              Did I answer your question? Mark my post as a solution!
       

Proud to be a Datanaut!


   


jsimon Frequent Visitor
Frequent Visitor

Re: Latest date in dataset not displaying on reports

Hi,  Thanks for your response...  That's what I originally thought, but after rolling my PBI back to Version: 2.46.4732.721 64-bit (May, 2017) (same data and no adjustments to filters) my numbers are fine...??...

Ross73312 Super Contributor
Super Contributor

Re: Latest date in dataset not displaying on reports

Strange!  I've been updating to new versions each month and not running into any problems like that.

 

Are you running 32bit or 64bit version?

 

EDIT: Dur, 64-bit is written clearly in your message.  I don't know what else to suggest.


   

              Did I answer your question? Mark my post as a solution!
       

Proud to be a Datanaut!


   


jsimon Frequent Visitor
Frequent Visitor

Re: Latest date in dataset not displaying on reports

64...  I know, right...?  odd... 

Community Support Team
Community Support Team

Re: Latest date in dataset not displaying on reports

Hi @jsimon,

 

If you can please provide a sample pbix file to test, it is hard to reproduce your issue without any sample data.(not need the real data, you can split part of your records or create a fake table with similar table  structure)

 

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin Sheng
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.



For learning resources/Release notes, please visit: | |

Helpful resources

Announcements
Back to School Contest

Back to School Contest

Engage and empower students with Power BI!

MBAS Gallery

Watch Sessions On Demand!

Continue your learning in our online communities.

Summit Australia 2019

Summit Australia 2019

Travel to Melbourne and network with thousands of peers!

PBI Community Highlights

PBI Community Highlights

Check out what's new in the Power BI Community!

Top Ideas
Users Online
Currently online: 22 members 933 guests
Please welcome our newest community members: