cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Keyset as registered is invalid.

Hello Everyone,

My personal gateway was working fine but then I decided to use the the updated version (on -premises gateway (personal mode) ), The installation went well, then i opened it, enterered my account/pwd, and it pop up error: Keyset as registered is invalid. I did almost every thing i-e.  uninstall gateway , Reinstall .Net Framework 4.7.2 , re boot , reinstall, rename folder

Keyset as registered is invalid"

Please advice how to resolve this error

6 REPLIES 6
Highlighted
Super User IV
Super User IV

@Nosheen maybe it is worth opening a support ticket, not sure why it would be the case. Is it a personal or enterprise gateway? Do you want to try and test on another machine?

 

I would  Kudos if my solution helped. 👉 If you can spend time posting the question, you can also make efforts to give Kudos whoever helped to solve your problem. It is a token of appreciation!

Visit us at https://perytus.com, your one-stop shop for Power BI related projects/training/consultancy.






Did I answer your question? Mark my post as a solution.

Proud to be a Super User! Appreciate your Kudos 🙂
Feel free to email me with any of your BI needs.





Highlighted

I recenlty uninstalled gateway on my laptop and then installed it again. I did not encounter any issue.

It did prompt me that there is previously configured gateway and will be udpated

Highlighted

Hi ,

Unfortunately , I am only having machine (my company laptop) and I need this to be working there. Its a on prem gateway (personal mode). 

Thanks

Highlighted

Hi @Nosheen 

 

The Gateway cannot be on Premesis and Personal at the same time. I had the same issue before, the Gateway administrator needs to Uninstall the gateway, reboot the server, and reinstall the new version. All done by the administrator of the server as well as the Gateway.

 

Good luck  

Regards
Amine Jerbi
https://www.linkedin.com/in/amine-jerbi-2b3a8928/

Did I answer your question? Mark my post as a solution!
Highlighted

Hi @Nosheen 

Please delete your old gateway (personal) first, then install a new update one.

It doesn't support for two gateway (personal) installed on one server.

 

Best Regards

Maggie

Highlighted

Hi Maggie, 

I already tried this one. As far as I suspect, there is something stuck at my local machine that is causing this error as I tried to create gateway from another machine and I didnt get any error. I already tried to rename RSA , Crypto etc but nothing working. I need gateway to work from this machine.

Please advise how can I erase previous keyset from my local machine?

Thanks

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Community Conference

Microsoft Power Platform Communities

Check out the Winners!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors