Reply
Frequent Visitor
Posts: 6
Registered: ‎06-02-2018
Accepted Solution

Keep spaces in column fields when using table/matrix

[ Edited ]

Hi,

 

I'm struggling to create my own indentation in a table visualisation.

I have a 'Description' Column with all my P&L Lines and an Indent column with numbers. I created a new column using Text.repeat(" ",[Indent]) function so as to indent each line using the number in Indent column.

This works well and each line appears with spaces before the name in the DATA tab of PowerBI Desktop.

 

However, whenever I use the new column in a table or matrix, powerbi automatically remove all spaces before the name. Therefore the indentation is not visible.

 

How to keep spaces before the name of the field ?

 

EDIT

From the example of thebiccountant

 

What I want is the left tab but I always get the right one :

 

Spaces_PBI.PNG

 

 


Accepted Solutions
Community Support Team
Posts: 5,399
Registered: ‎09-21-2016

Re: Keep spaces in column fields when using table/matrix

Hi @Lichar,

 

Please turn off the "Word Wrap" option under Format pane.

1.PNG

 

Best regards,

Yuliana Gu

View solution in original post


All Replies
Community Support Team
Posts: 5,399
Registered: ‎09-21-2016

Re: Keep spaces in column fields when using table/matrix

Hi @Lichar,

 

Please turn off the "Word Wrap" option under Format pane.

1.PNG

 

Best regards,

Yuliana Gu

Highlighted
Frequent Visitor
Posts: 6
Registered: ‎06-02-2018

Re: Keep spaces in column fields when using table/matrix

Thanks for your reply. It works well.

 

I was also able to bypass this behaviour by inserting a different kind of spaces (full width) : [ ]

 

 

Lichar