cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
TorbenM Frequent Visitor
Frequent Visitor

KPI Visual showing Blank when target is added

Hi, 

 

I have come across a strange behaviour of the KPI-Visual that I seem not be able to solve:

 

I Have two measures. One of them calculates some percentage the other one just uses a simple formular to "calculate a fixed target":

value 0.97 = 0,97

 

I want to use these two Measures in a KPI Visual but get Blank as result. The interesting thing is, that if I switch aroung "indicator" and "target goal" I get a number. But of course the number is wrong for my purpose.

 

Also when I just add the indicator without the target I get a number back. Only when I combine the two fields  in one certain way I get Blank.

 

I have no clue what causes this behaviour. I would at least have expected that it shows BLANK in both cases. Here is a picture that explains the problem:

 

KPI Chart problem.png

 

Thanks in advance for your help.

 

BR,

Torben

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: KPI Visual showing Blank when target is added

Hi @TorbenM ,

Please refer to the following example:

Assume that I have a table like below:

PBIDesktop_8HY4288TDR.png

Then I create a measure as the target like below:

value = 205

Then drag these columns to the related field, the result like below:

PBIDesktop_DwSNm79IKN.png

Best Regards,

Teige

View solution in original post

3 REPLIES 3
Community Support Team
Community Support Team

Re: KPI Visual showing Blank when target is added

Hi @TorbenM ,

Please refer to the following example:

Assume that I have a table like below:

PBIDesktop_8HY4288TDR.png

Then I create a measure as the target like below:

value = 205

Then drag these columns to the related field, the result like below:

PBIDesktop_DwSNm79IKN.png

Best Regards,

Teige

View solution in original post

BSacchini Frequent Visitor
Frequent Visitor

Re: KPI Visual showing Blank when target is added

Hello. I am having the same problem.

 

I know why it is happening although I havent been able find a way around the issue.

 

I created two measures: 1) A measure I want to track using KPI and 2) A "fixed" measure that indicates the treshold for my KPI goal (e.g: 10). 

When I create my KPI I want it to have a trend axis (date hierarchy by months). 

 

So basically the problem is that my first measure (the one I am looking to track) comes from a table that is up to the maxcurrentdate, while the second measure (the fixed goal) comes from a table that is populated for the entire year (see picture). So logically the KPI will analyze the last given month, which has a Fixed Goal but has no value for the measure that I want to track, hence I get the BLANK result.

 

How do I set my Goal Measure to only provide values for current or past months?

 

EGKPI.pngThanks

 

 

 

varamati Visitor
Visitor

Re: KPI Visual showing Blank when target is added

@TeigeGao ,

In the example specified, I want to have a dynamic goal i.e median(column1). How can I specify goal here?

 

If I create a calculated measure for the median to fix this, it is rendering blank.

 

Thanks in advance,

Veda

Helpful resources

Announcements
Exclusive LIVE Community Event #3 – Ask Arun Anything

Exclusive LIVE Community Event #3 – Ask Arun Anything

Join us in the third Triple A event!

Meet the 2020 Season 1 Power BI Super Users!

Meet the 2020 Season 1 Power BI Super Users!

It’s the start of a new Super User season! Learn all about the new Super Users and brand-new tiered recognition system.

Super User Challenge: Can You Solve These?

Super User Challenge: Can You Solve These?

We're celebrating the start of the New Super User season with our first ever Super User 'Can You Solve These?' challenge.

January 2020 Community Highlights

January 2020 Community Highlights

Make sure you didn't miss any of the things that happened in the community in January!

Top Solution Authors