cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
arturosso Frequent Visitor
Frequent Visitor

KPI Indicator - color for "None" value does not work

Dear All,

 

I tried to show black KPI that has no actuals and unfortunately it did not work. Please see below.

 

Testing scenario 1:

 

The actual and target value at IE in 2016-12 are both empty – see (1) below.

The KPI set up allows to define color for Good, Neutral , Bad and None – see (2).

The KPI box background color is still green even though it should be black – see (3).

 

 

 pbi01.jpg

 

 

 

Testing scenario 2:

 

The data row for IE in 2016-12 does not exist – see (1).

The KPI set up allows to define color for Good, Neutral , Bad and None – see (2).

The KPI box background color is still green even though it should be black – see (3).

 

 pbi02.jpg

 

 

Could you tell me if this is a bug or I'm doing something wrong?

 

Cheers,

Artur

 

14 REPLIES 14
shill1000 Member
Member

Re: KPI Indicator - color for "None" value does not work

Without any detail behind how you are getting a value for the KPI its difficult to diagnose, but my first thought is have you accounted for the difference between 0 and NULL? If you are using a mathematical function to validate against, it could very well be that there is no data to validate as opposed to a value of 0?

arturosso Frequent Visitor
Frequent Visitor

Re: KPI Indicator - color for "None" value does not work

Hi shill1000,

 

on the SQL query level in Scenario 1 the values for actual and tagert are both NULL. I can change the query however I want, I just need to be able to display black background when there's no data instead of green. I also tried other combinations for actual/target e.g. NULL/zero, zero/zero etc. and I've never got black background.

 

What are you suggesting to change here in order to achieve black background for "None" value?

 

Cheers,

Artur

shill1000 Member
Member

Re: KPI Indicator - color for "None" value does not work

Have you tested it with a 0 value instead of Null?

 

I'd also question how you have a value with no target. In the context why would you report on a sales item that has not value or target? perhaps if you explained the context of the report it would help with a solution.

arturosso Frequent Visitor
Frequent Visitor

Re: KPI Indicator - color for "None" value does not work

Yes, I've tested all the combinations of Actual/Target values  - see below zero/zero combination.

 

pbi3.png

 

From the business perspective it is important to see black color (instead of green/red which suggest that we're dong good/bad) so that the users see that the data for a certain month is missing and they need to provide it.

 

Do you have any ideas if this is a bug or I'm doing somehting wrong?

 

Thanks,

Artur

shill1000 Member
Member

Re: KPI Indicator - color for "None" value does not work

Only thing I can suggest is share the detail of the KPI.  Is it a measure and/or coming from the DB source data?

arturosso Frequent Visitor
Frequent Visitor

Re: KPI Indicator - color for "None" value does not work

The data source of this KPI is SQL Server database and the query output looks like this:

 

pbi04.PNG

 

The underlined row is the source for 2016-12 IE value (both Actuals and Target = NULL in Scenario 1). 

 

I'm my previous post when I tested zero/zero combination it looked like this:

 

pbi05.PNG

 

Please advice.

 

Cheers,

Artur

 

 

shill1000 Member
Member

Re: KPI Indicator - color for "None" value does not work

Artur,

 

As I indicated, share the detail of the KPI. Unless we can see the way it's functioning (not just the results) nobody can help you further.

arturosso Frequent Visitor
Frequent Visitor

Re: KPI Indicator - color for "None" value does not work

The visual is called "KPI Indicator", the configuration is shown in the below screenshots.

 

 

pbi06.PNGpbi07.PNGpbi08.PNGpbi09.PNG

 

If there's something specific that you want me to share please just explain exactly what you need and I'll provide it to you. I hope this can help ypu replicate the issue and advise.

 

Cheers,

Artur

shill1000 Member
Member

Re: KPI Indicator - color for "None" value does not work

Artur,

 

You're not explaining the source of the KPI. Are you using a measure or getting the KPI as a field from the database? The nature of the KPI will determine the value/data type it is producing and thus how it is being handled by Power BI.

Helpful resources

Announcements
October 2019 Community Highlights

October 2019 Community Highlights

October was a busy month in the community. Read the recap article to learn about some of the events and content.

New Badges

Incoming: New and Improved Badges

Exciting news: We've given our badges an overhaul and added brand news ones.

Ask Amir Anything

Exclusive LIVE Community Event No. 2 – Ask Amir Anything

Next in our Triple A series: Ask Amir Netz questions about the latest updates, features and future.

Analytics in Azure virtual event

Analytics in Azure virtual event

Experience a limitless analytics service built to ingest, prep, manage, and serve data for immediate use in Power BI.

Users Online
Currently online: 227 members 2,510 guests
Please welcome our newest community members: