cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Maximus
Frequent Visitor

KPI Indicator Showing "(BLANK)"

What is causing my KPI card indicator to show blank?

 

Capture.PNG

 

The indicator is the following:

Total Cumulative Spend = CALCULATE (
   [Total Spend],
    FILTER (
        ALL ( 'Date'[Month] ),
        'Date'[Month] <= MAX ( 'Date'[Month] )
    )
)

Any ideas why my card is showing "(BLANK)" in the indicator?

7 REPLIES 7
JohnnyHernandez
New Member

I created a field called Current Year which is just "Current Year = YEAR(TODAY())"

 

Anyways, I dragged that field into the Trend Axis and it solved my problem.

anwar_b_uk
Frequent Visitor

did anyone fix this , i am getting the same issue that affects only KPIS

if i put the measure in a card i get a 0 if its blank or the total but if i put the same measure in a kpi all i get is a 0 even though in the card it has a value .

Anonymous
Not applicable

The KPI measure will display blank when it evaluates to blank and the KPI goal is not blank. A good way to visualize this scenario is to add the KPI measure and goal to a table with the same filters as the KPI visual. Here is an example:

 

PowerBI_KPI_Blank.png

 

One way to fix this is to use a measure for the KPI goal (Which is a good practice anyway), and only display the goal when the measure is not blank.

 

KPI Measure Goal :=
IF ( ISBLANK ( [KPI Measure] ), BLANK (), 258051 )

dearwatson
Responsive Resident
Responsive Resident

I dont see anything that stands out as wrong... might need a sample link or check all the measures/data to help.

 

Cheers

Greg

"The commonality between science and art is in trying to see profoundly - to develop strategies of seeing and showing." - Edward Tufte

I had this happen and preferred a Zero so instead of using a measure as my target value, I used a column and it worked


@dearwatson wrote:

I dont see anything that stands out as wrong... might need a sample link or check all the measures/data to help.

 

Cheers

Greg


Just to see what's exactly is going on I created two visuals--KPI card with just the Total Cumulative Spend and a matrix with the breakdown of the Total Cumulative spend by month. The KPI card is showing the most recent (June) spend amount which is $1.05M but it should be showing the total spend from January - June. Any idea why it's doing that?

 

1.PNG

Hi @Maximus,



The KPI card is showing the most recent (June) spend amount which is $1.05M but it should be showing the total spend from January - June. Any idea why it's doing that?

 


This is the expected result for KPI visual on Power BI. Only the last indicator value will be shown according to the Trend axis on the KPI visual currently. Smiley Happy

 

Regards

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

March Update

Check it Out!

Click here to read more about the March 2021 Updates!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.

secondImage

Experience what’s next for Power BI

See the latest Power BI innovations, updates, and demos from the Microsoft Business Applications Launch Event.