cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
aTChris Resolver I
Resolver I

Issue with row height in matrix

Im having a really strange issue. I have a matrix with mostly numerical data points but there are two columns with text. One of these columns is a comment which has a variable amount of characters. The matrix was set with word wrap disabled but the most recent dataset includes comments which are being trimmed. I, therefore, enabled word wrap.

 

The issue is that all rows are now three lines in height. Row Padding is set to 0 and I've just read that line breaks are removed from carriage returns on data import. I can't work out what is causing the matrix to expand all rows to such a height.

 

Any ideas.?

1 ACCEPTED SOLUTION

Accepted Solutions
aTChris Resolver I
Resolver I

Re: Issue with row height in matrix

@Pragati11 

 

I've figured out the cause of the issue, there is no solution.

 

I have added an index column to allow me to order by index, this allows me to show the data as per the data source and not as power bi wants to. The trick I use is to hide the col by making the width near 0 but that only works with word wrap off. When I enable it to show the comments the index col then goes three lines in height.

 

So I cant order by index and have word wrap enabled.

View solution in original post

3 REPLIES 3
Pragati11 Resident Rockstar
Resident Rockstar

Re: Issue with row height in matrix

Hi @aTChris ,

 

It will be easier to answer you question if you share some screenshots or .pbix file.

 

Thanks,

Pragati

aTChris Resolver I
Resolver I

Re: Issue with row height in matrix

@Pragati11 

 

I have to obfuscate the data, below is word wrap off, then on. Row Padding = 0. I can't find any reason why it's adding the extra space and on all rows, not just the rows that need to wrap text.

 

wrapwrapoff.png

 

wrapwrapon.png

aTChris Resolver I
Resolver I

Re: Issue with row height in matrix

@Pragati11 

 

I've figured out the cause of the issue, there is no solution.

 

I have added an index column to allow me to order by index, this allows me to show the data as per the data source and not as power bi wants to. The trick I use is to hide the col by making the width near 0 but that only works with word wrap off. When I enable it to show the comments the index col then goes three lines in height.

 

So I cant order by index and have word wrap enabled.

View solution in original post

Helpful resources

Announcements
Announcing the New Spanish Forum

Announcing the New Spanish Forum

Do you need help in Spanish? Check out our new Spanish community section.

April 2020 Community Highlights

April 2020 Community Highlights

Info on our Super Users, MBAS content and badges, and updates to our support articles. - Read the full Community Highlights.

MBAS Gallery 2020

MBAS Gallery 2020

Watch Microsoft Business Applications Summit sessions on-demand.

Top Solution Authors
Top Kudoed Authors