cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
pradeep467
Helper II
Helper II

Issue opening PBIX file (We werent able to restore the saved database to the model)

Hi,

I am having issues opening my PBIX file, I upgraded my desktop version to the latest June version and made all the changes, I saved it and closed the file. But when I am trying to open the file it pops me an error message "(We werent able to restore the saved database to the model)"  I wasnt sure how to get back my changes, I tried uninstalling the desktop and reinstall and also tried opening the file in my colleagues machine which has May version and even that did not help. Please suggest

18 REPLIES 18
v-xuding-msft
Community Support
Community Support

Hi @pradeep467 

 

I can’t reproduce your issue . Can  I ask you some questions? Please let me know the details below.

 

  1. Is this happening in all the reports, or is this one only happening?
  2. Do you installed the latest 64-bit vision (2.70.5494.761) ? if not, please de-installing and re-installing.

 

If you failed again, there is a way you can have a try from this link

As a temp fix you can try disabling the optimized FileSave:

 

  1. Close the PBIDesktop application
  2. Control Panel>System>Advanced system settings>Environment Variables
  3. User variables... New...

Variable name: PBI_fastLoadSave

Variable value: false

  1. Start PBIDesktop and try to open file

 

Best Regards,

Xue Ding

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Best Regards,
Xue Ding
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks for responding, I tried all the steps listed out and also unistalling and installing, unfortunately nothing helped. I am still getting the same error.

Ensure you have access to the database refrenced in your pbix, from the machine you are trying to open the file.

Sometimes, if the underlying data is no more accessible, you might see that error message.

@tarunsingla  I still continue to have access to that databse, If i am opening an arlier file I am able to open and run reports.

You mentioned that you are able to open and run an earlier version of the report file. That means the issue is not in the latest update of Power BI Desktop but might be in the latest version of pbix file that you are trying to open.

 

Was the file opened/saved directly from/on a Sharepoint site or from/on OneDrive? Sometimes pbix files do not get saved properly when opened directly from a Sharepoint/OneDrive.

If it was from there, any possibility to see if there are other previous (but recent) versions of the file that were saved on the Sharepoint/OneDrive.

Yes Tarun, so currently I am using the one I had like 4 days prior version to the corrupted and ended up redoing all the chnages. But would like to know the root cause of this or if in future I come across this issue, is there a way to retreive the corrupted file. How do you do the version controlling, like everyday we make a lot of changes right, so do we need to create separate files based on day to avoid  the redo efforts?

Personally, I do not work on my pbix files directly from the OneDrive. I work on my report files on my system and save as many times as I prefer (which is a lot), and copy paste (to overwrite) the files on OneDrive only a few times (the number of verions I am comfortable having on OneDrive).

I have myself ran into issues working on pbix files directly from OneDrive and hence do not prefer that approach.

If you want to version control your report files, I would recommend other code repositories (like TFS) than OneDrive/Sharepoint.

Thanks for the info Tarun. we are working with Microsoft to debug this issue.

Is there any udpates on the issue?

 

Seems like I have the exact problem. 

 

Thanks

janhed
Frequent Visitor

I also starting to get this error today, also tried to create a new report, save it and when I open it I get the same error.

mcaglidil
Frequent Visitor

I've reported the problem to the PBI team but seems like I cannot open any files anymore. I've tried all possible solutions in the forum but seems like none've worked for me. 

 

I would appericiate if the PBI team looks into the problem asap. 

 

Thanks,

 

janhed
Frequent Visitor

I just installed a Power BI desktop version prior to the February 2020 and now I can open my .PBIX files again. 

mcaglidil
Frequent Visitor

I've tried the same but the problem is still persisting. 

 

Did you deleted also the older files manually? 

 

Thanks

janhed
Frequent Visitor

No after installing the November 2019 Power BI Desktop edition, I could open all my old .PBIX files.

mcaglidil
Frequent Visitor

Hi there,

 

Maybe little silly question, can you please share the link that you've used downloading the November 2019 edition? 

 

Thanks

janhed
Frequent Visitor

janhed
Frequent Visitor

Thanks. Please post if you getting to a solution. And I have also tried different proposed solutions without any positive result.

Sure @pradeep467. Could you please update this thread once you get a solution.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Get Ready for Power BI Dev Camp

Power BI Dev Camp - June 24th

Mark your calendars and join us for our next Power BI Dev Camp!

Top Solution Authors
Top Kudoed Authors