cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
shaunguyver
Helper III
Helper III

Image viewer working for Web URL, not for One Drive or SharePoint

I have an image viewer connected to the below data set.

 

All of the images hosted on the public web work when selected, but when images are hosted on SharePoint or OneDrive, they come up with a broken link.

 

I have changed image field to 'Image URL' data type, but this has no effect.

 

Anybody know how I can link image URLs to SharePoint/One Drive and get it work work?

 

screenshot.jpg

1 ACCEPTED SOLUTION

Hi @shaunguyver,

 

In order to make the image address work, we should make sure that that you can share the files to anyone. Please ask your administrator  to change the setting in the Admin for one drive.

 

1.png

 

Then share the file to anyone and copy the link.

 

2.png

 

Paste the link to your browser, after the image has been loaded, copy the image address.

 

3.png

 

At last we can use the URL with no issue. Please check the result as below.

4.png

 

This way might be a bit complex, so I suggest you to use the OneDrive for personal instead of the Business.

 

Regards,

Frank

Community Support Team _ Frank
If this post helps, then please consider Accept it as the solution to help the others find it more quickly.

View solution in original post

6 REPLIES 6
Abduvali
Skilled Sharer
Skilled Sharer

Hi @shaunguyver ,

 

See my solution in a similar thread!

https://community.powerbi.com/t5/Desktop/Unable-to-use-OneDrive-Business-share-link-to-display-image...

 

 

Please mark the solution if works for you.

Regards

Abduvali

v-frfei-msft
Community Support
Community Support

Hi @shaunguyver,

 


For One drive for business, Based on my test, we can get the URL of the images by opening the images in web browser and selecting “copy image address”. Then you should see the picture after changing image field to 'Image URL' data type.

 1.png2.png

 

For One drive for personal, we can get the URL directly by this way.

 

3.png

 

For SharePoint online, I suggest you contact your admin to check if he has enabled “Allow sharing to authenticated external users and using anonymous access links” and “Anonymous Access - anyone with the link in Sharing” in SharePoint Admin Center. Then you can get the link of the images in SharePoint following the steps in this similar thread.

4.png.

 

Regards,
Frank

Community Support Team _ Frank
If this post helps, then please consider Accept it as the solution to help the others find it more quickly.

Thanks for your detailed reply - I managed to get your solution for OneDrive for business working, by simply opening the image in my browser and copying the link. It actually produces the '....image.jpg' URL, which works.

 

However, this only works for the first image in my list of images. Every other image I have uploaded (they go from 'building1.jpg' through to 'building15.jpg') shows the broken link pic. All filenames are consistent, and the slicer produces the correct URL in a test table I have placed next to my image viewer visual. However, it seems to only want to show the first one.

 

Any idea why this might be? I'd upload my file, but the dataset links to one drive so would assume won't work on your local machine.

 

Thanks,

Hi @shaunguyver,

 

In order to make the image address work, we should make sure that that you can share the files to anyone. Please ask your administrator  to change the setting in the Admin for one drive.

 

1.png

 

Then share the file to anyone and copy the link.

 

2.png

 

Paste the link to your browser, after the image has been loaded, copy the image address.

 

3.png

 

At last we can use the URL with no issue. Please check the result as below.

4.png

 

This way might be a bit complex, so I suggest you to use the OneDrive for personal instead of the Business.

 

Regards,

Frank

Community Support Team _ Frank
If this post helps, then please consider Accept it as the solution to help the others find it more quickly.

Hi - this seems to work now, it just wasn't working in desktop viewer. In the browser it works fine. Thanks for your help!

Hey, 2 years later, did you find the solution for the Desktop app? It's happening the same to me.

Also in Teams I'm not able to see them, but in Chrome they works fine

Helpful resources

Announcements
August 2022 update 768x460.jpg

Check it Out!

Click here to learn more about the August 2022 updates!

August 1 episode 9_no_dates 768x460.jpg

The Power BI Community Show

Watch the playback when Priya Sathy and Charles Webb discuss Datamarts! Kelly also shares Power BI Community updates.

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Top Solution Authors
Top Kudoed Authors