cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
aka Regular Visitor
Regular Visitor

How to turn off impersonation

I am getting an error message whils accessing the dataset on my computer which was shared to me by my friend to create report on . Error is  (Impersonation is not supported in DirectQuery mode. Turn off impersonation or switch to import mode.).  I don't see anywhere within Power BI where you turn off impersonation. What does impersonation do?  Does anyone know where to go to turn this off?  Thanks in advance for your help

1 ACCEPTED SOLUTION

Accepted Solutions
Moderator v-sihou-msft
Moderator

Re: How to turn off impersonation

@aka

 

You can go to Data Source setting. Edit your data source and specify a valid credential instead of using current account.

 

88.PNG

 

 

87.PNG

 

Regards,

3 REPLIES 3
Moderator v-sihou-msft
Moderator

Re: How to turn off impersonation

@aka

 

You can go to Data Source setting. Edit your data source and specify a valid credential instead of using current account.

 

88.PNG

 

 

87.PNG

 

Regards,

Zaka Frequent Visitor
Frequent Visitor

Re: How to turn off impersonation

Its not working with direct query mode...

apayze Frequent Visitor
Frequent Visitor

Re: How to turn off impersonation

I have the same issue and I used the Alternate credentials, however the problem persists.  Is there another solution?

 

Is it related to a setting in SQL maybe?

 

Andrew