cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

How to turn off "Use a date gateway"

Hi,

I have been using Enterprise Data Gateway to update several datasets but I need to disable one of them.

But I noticed that somehow I cannot disable or turn off the option as circled in the screenshot,

Do I need to remove the gateway entirely ?  Can't I just disable data refresh ?

Thanks

 

Capture.PNG

1 ACCEPTED SOLUTION
Anonymous
Not applicable

Based on the screenshot I note 2 things:

 

  • No schedule is set up, so no automatic refresh would occur
  • The message in your screenshot indicates you have a datamodel with a direct connection instead of import.

 

The 2nd point is most important as a direct connection model does not store a full dataset.  There is no refreshing as the data sources are queried while the reports are being used.

 

If you want to have a cached copy of the dataset, change your model to import and republish.

View solution in original post

5 REPLIES 5
Anonymous
Not applicable

Based on your question, it sounds like you don't actually want to remove the gateway, what you want to do is prevent the scheduled refresh?

 

If that is true, go down further and look for the section labeled "Scheduled refresh". There is a toggle called "Keep your data up to date".  If you toggle this off, your data won't refresh automatically.

 

You can still manually refresh anytime.

Anonymous
Not applicable

Yes, you are right, I am just trying to disable scheduled data refresh for now.

And thanks for a quick reply, but I don't see  "Keep your data up to date" under "Scheduled cache refresh" as in the screenshot.

Am I looking in the wrong place ?

 

Thanks in advance

capture2.PNG

 

 

Anonymous
Not applicable

Based on the screenshot I note 2 things:

 

  • No schedule is set up, so no automatic refresh would occur
  • The message in your screenshot indicates you have a datamodel with a direct connection instead of import.

 

The 2nd point is most important as a direct connection model does not store a full dataset.  There is no refreshing as the data sources are queried while the reports are being used.

 

If you want to have a cached copy of the dataset, change your model to import and republish.

I actually do want to turn off a gateway connection.  How do I do that?  

Anonymous
Not applicable

Firstly you'd need to convert the data model to be import, republish and then select the toggle in the "Datasets" settings menu -> Data Gateways.

 

While you have this model set as direct connection, the ability to disable/enable the gateway is prevented.  This is because a direct connection report has no data without the gateway and wouldn't work.

Helpful resources

Announcements
Carousel_PBI_Wave1

2023 Release Wave 1 Plans

Power BI release plans for 2023 release wave 1 describes all new features releasing from April 2023 through September 2023.

Power BI Summit Carousel 2

Global Power BI Training

Make sure you register today for the Power BI Summit 2023. Don't miss all of the great sessions and speakers!

Thank you 2022 Review

2022 Monthly Feature Releases

We had a great 2022 with a ton of feature releases to help you drive a data culture.