cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
KomTruize
Regular Visitor

How to disable the Power BI welcome window

 

Hi,

 

at every start up of Power BI desktop, I have the full page, welcome / get started page, even if the checkbox "Show this screen on startup" is unchecked.

 

Any advice?

Thanks

 

welcome page.jpg

7 REPLIES 7
WindAnalytics
New Member

Hello,

 

Has anyone figured this out?

 

I have Power BI Desktop (February 2021) installed and every time I start it I get the Welcome screen, even though I'm logged in and "Show this screen on startup" is unchecked.  I saw the same behavior with the January 2021 verison.

 

Thank you!

Okay, I think I am on to something.

 

Whenever I start Power BI I seem to be "semi" signed in.

 

Three places seem to exist that are related to account and "Sing in"/"Sign out" options.

 

There are two "Sign In"/"Sign out" places: 1) the right side of Power BI window's title bar and 2) furthest down in the File menu.

 

There are also two places that show the name of the logged in user: 1) the top right side of the "Welcome window" (or Get started window) and 2) the right side of Power BI window's title bar.

 

The "Welcome window" (or Get started window) always shows my name after I log in once. In other words, whether I restart Power BI Desktop or restart my PC, the Welcome window always remembers me.

 

But when if any of the two "Sign in"/"Sign out" places show "Sign in" (indicating that I'm signed out) the unchecked "Show this screen on startup" setting is not respected. But after I sign in, and my name is shown in the title bar and the File menu entry shows "Sign out", the unchecked  "Chow this screen on startup" is respected, if and only if, Power BI desktop remembers the signed in state after a restart of Power BI Desktop. However, in my case, it rarely remembers.

 

Any suggestions anyone?

 

EDIT:

Seems related to: https://community.powerbi.com/t5/Desktop/Power-BI-Desktop-asking-for-login-on-every-start-up/m-p/251...

KomTruize
Regular Visitor

Hi, that doesn't work for me.

 

Even tried a full uninstall, new installation, every single time the welcome screen opens

Eyelyn9
Community Support
Community Support

Hi @KomTruize ,

 

I also encountered the same issue before. Even if I uncheched the Show this screen on startup option, the screen still appeared until now...

12.15.2.1.PNG

 

Yestday ,I tried to check the option ,close Power BI Desktop and open and uncheck again, it seemed work.

But today when I open again ,the welcome screen also appear again...

So I doubt it's a timeliness phenomenon.

 

Please have a try.

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Best Regards,
Eyelyn Qin

PhilipTreacy
Super User III
Super User III

Hi @KomTruize 

Ensure you have the latest update for PBI Desktop.

Also try setting ShowLeadGenDialog = 0 (dword) in the registry hive HKLM\SOFTWARE\Policies\Microsoft\Power BI Desktop and/or in HKCU\SOFTWARE\Microsoft\Power BI Desktop

Refer to https://community.powerbi.com/t5/Desktop/Disable-quot-Welcome-to-Power-BI-Desktop-quot-Nag-Screen/td...

Regards

Phil

 



Did I answer your question? Then please mark my post as the solution.
If I helped you, click on the Thumbs Up to give Kudos.


Blog :: YouTube Channel :: Connect on Linkedin


Proud to be a Super User!


hi Phil,

I was not abble to find anything about Power BI neither in HKEY_USERS, HKEY_CURRENT_USER nor in HKEY_LOCAL_MACHINE...

 

Even with search, I tried many combinaisons of word (with space, without...), no trace of Power BI in my windows registry !

 

And just in case, recent Windows 10 Pro PC, no antivirus, I tried a fresh reinstall of Power BI.

negi007
Super User II
Super User II

@KomTruize  I have unchecked the option to show the startup window and then saved the file. When i reopen my powerbi desktop i do not get this startup screen. Please ensure that you save and close your powerbi and then when you open the screen should not appear on starting the powerbi. This option is working for me so should work for you as well. Also ensure that you have the latest version of powerbi install that may also help you.




Did I answer your question? Mark my post as a solution!
Appreciate your Kudos


Proud to be a Super User!

Follow me here


Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

April Update

Check it Out!

Click here to read more about the April 2021 Updates!

MBAS Carousel

Sign up for our May 4th event!

May the fourth be with you, join us online!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.