cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
fileonlineservi
Regular Visitor

How i can show the sharepoint item's Modified Date in a single field inside my Power BI report

I have this SharePoint fields which i am showing inside Table:-

 

fileonlineservi_0-1667991909616.png

 

all fields are showing well, except for the Modified >> where it will be shown into 4 seperates columns inside the table (Year,quarter,Month & Day) without the time, can this be joint into a single field (showing the date & time) which i can sort and filter based on it? similar how the Modified date is shown inside sharepoint list view? Thanks

 

1 ACCEPTED SOLUTION
MDodds
Resolver II
Resolver II

Hi Fileonelineservi,

 

This happens because of the automatic hierarchy Power BI applies against date fields.

There are two easy ways to fix this:

 

  1. Once you have added the Modified to your table, select the drop down arrow in the cisualisation pane and switch it from "Date Hierarchy" to "Modified" per the below two images.
    MDodds_0-1667992498714.pngMDodds_1-1667992525396.png

     

    This changes it off hierarchy view. If you still don't like the date format, you can select the modified date field in your table and then go to the format pane and change the format per the below.

    MDodds_2-1667992587979.png

     

  2. The second way to avoid this is to turn off the setting that automatically applies the hierarchy in the first place.
    You can do this with the below:

    Go to  File --> Options and Settings --> Options --> Current File -> Data Load 

    and turn  off 'Auto Date/Time' (under Time Intelligence)

Good luck and let me know if you need further assistance.

 

Cheers

View solution in original post

2 REPLIES 2
fileonlineservi
Regular Visitor

@MDoddsworked like a magic thanks a lot

MDodds
Resolver II
Resolver II

Hi Fileonelineservi,

 

This happens because of the automatic hierarchy Power BI applies against date fields.

There are two easy ways to fix this:

 

  1. Once you have added the Modified to your table, select the drop down arrow in the cisualisation pane and switch it from "Date Hierarchy" to "Modified" per the below two images.
    MDodds_0-1667992498714.pngMDodds_1-1667992525396.png

     

    This changes it off hierarchy view. If you still don't like the date format, you can select the modified date field in your table and then go to the format pane and change the format per the below.

    MDodds_2-1667992587979.png

     

  2. The second way to avoid this is to turn off the setting that automatically applies the hierarchy in the first place.
    You can do this with the below:

    Go to  File --> Options and Settings --> Options --> Current File -> Data Load 

    and turn  off 'Auto Date/Time' (under Time Intelligence)

Good luck and let me know if you need further assistance.

 

Cheers

Helpful resources

Announcements
Carousel_PBI_Wave1

2023 Release Wave 1 Plans

Power BI release plans for 2023 release wave 1 describes all new features releasing from April 2023 through September 2023.

Power BI Dev Camp Session 30

Ted's Dev Camp - January 26, 2023

This session will provide guidance and teach campers the skills required to build Power BI reports that support multiple languages.

Power BI Summit Carousel 2

Global Power BI Training

Make sure you register today for the Power BI Summit 2023. Don't miss all of the great sessions and speakers!

Thank you 2022 Review

2022 Monthly Feature Releases

We had a great 2022 with a ton of feature releases to help you drive a data culture.