cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
GunnerJ
Helper V
Helper V

Hiding Filter Pane on Powerbi Report view

I have a few reports that we're wanting to share with users but we don't want them possibly messing with the underlying filters and therefore would like the Filters Pane hidden in the report view. I would use the dashboard view but we want users to be able to uses drill down functionality so that option is not viable. Is there a way to toggle off the filter pane? Thanks 

1 ACCEPTED SOLUTION
jdbuchanan71
Super User
Super User

In Power BI desktop you can click the eye icon on the top of the filter pane.

HideFilterPane.jpg

When the report is published the Filters pane will not be visable.

View solution in original post

12 REPLIES 12
jdbuchanan71
Super User
Super User

In Power BI desktop you can click the eye icon on the top of the filter pane.

HideFilterPane.jpg

When the report is published the Filters pane will not be visable.

View solution in original post

This is exactly what I was looking for.

 

Thanks,

karthik

I have 8 pages in my dashborad and "Filters on all pages" is enabled .Now i got a requirement where i have to disable/hide filter pane on Home page...Please help

@sattelli as shown in the accepted solution in the desktop view you should see the filters tab. From there click the "eye" to enable/disable the filters screen for the published version. This can be done page to page. 

sattelli
Frequent Visitor

Followed the same steps that you suggested but it didnt work..when i click on eye icon on any page , the filter pane would disappear in rest of the oages too which i dont want.

@sattelli It does seem like the filter panel is an all or nothing solution. I think the best solution for this is to disable the panel and create your own filter visuals to meet each page's needs. 

Hello,


I follow the above steps but when I publish the report I still have the problem of the filtes panel being open and visible by default. 

Any guidance would be greatly appreciated!

Hi, I had the same problem but then realised I had to turn off the filter panel in all my bookmarks, did this and the filter panel stopped showing.

thank you @BI_Jo 

I have the same issue.  Any news on this topic ?

 

Using PBi online, making reports visible in Teams but the filters are all still visible as long as each filter separately is not hidden.  So this general hiding button doesn't work for me.

 

Tx for any advice on what I could be doing wrong here.

Hi,

 

I was using the default code downloaded from the PowerBI website for the PowerBIEmbedded_AppOwnsData demo. If you open this project and drill down to EmbedReport.cshtml, there is code that is similar to this:

var config = {
        type: 'report',
        tokenType: models.TokenType.Embed,
        accessToken: accessToken,
        embedUrl: embedUrl,
        id: embedReportId,
        permissions: models.Permissions.All,
        settings: {
            filterPaneEnabled: true,
            navContentPaneEnabled: false,
            layoutType: models.LayoutType.MobileLandscape
        },
    };

Notice the configuration element setting filterPaneEnabled to true? This overrides whatever you set in the PowerBI desktop. 

Hope this helps you.


All the best,

Marcel

@theamazingarce 

I am not able to replicate your error (it works as described when I test it).  Are you working on the latest version of PowerBI desktop?

Helpful resources

Announcements
Power BI December 2021 Update_carousel 768x460.jpg

Check it Out!

Click here to read more about the December 2021 Updates!

User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Jan 2022 Dev Camp 768x460 copy.png

Power BI Dev Camp- January 27th, 2022

Mark your calendars and join us for our next Power BI Dev Camp!

Top Solution Authors
Top Kudoed Authors