cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
magnifybi
Resolver I
Resolver I

Help connecting External SQL Express to Power BI

Hey,

 

I need to access an external SQL Express server but am getting and error message;

 

"Details: "Microsoft SQL: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - The wait operation timed out.)""

 

Annonymised details as follows;

 

IP: 11.111.11.11

SQL Server –**-**-***\SQLEXPRESS 

 

I read somewhere that I need to put a port of 1433 but I'm not sure where I'm going wrong.

 

I have entered the username and password correctly

 

Thanks,

 

J

 

 

1 ACCEPTED SOLUTION
amitchandak
Super User
Super User

@magnifybi , In SQL Server configuration Manager -> Under Network -> Enable TCP/IP and Open properties, there you need mention port, that you want use externally

 

https://docs.microsoft.com/en-us/sql/relational-databases/sql-server-configuration-manager?view=sql-...

https://docs.microsoft.com/en-us/sql/database-engine/configure-windows/configure-client-protocols?vi...



Power BI Features || Datamarts: https://youtu.be/8tskWsJTEpg || Field Parameters : https://youtu.be/lqF3Wa1FllE?t=70
Time Intelligence Decoded : https://youtu.be/aU2aKbnHuWs&t=145s
Did I answer your question? Mark my post as a solution! Appreciate your Kudos !! Proud to be a Super User! !!
Dashboard of My Blogs !! Connect on Linkedin !! Subscribe to my youtube Channel !!
Want To Learn Power BI | Beginners !! Advance Concepts !! Power BI For Tableau User !!

View solution in original post

2 REPLIES 2
v-deddai1-msft
Community Support
Community Support

Hi @magnifybi ,

 

You can use servername or ip address+port(1433 for default instance). Would you please check if the browser service works well in server where the sql server is installed. And make sure you have enable TCP/IP protocol in sscm:

Capture.PNG

 

And also refer to the steps in https://docs.microsoft.com/en-us/sql/database-engine/configure-windows/troubleshoot-connecting-to-th...

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Best Regards,

Dedmon Dai

 

amitchandak
Super User
Super User

@magnifybi , In SQL Server configuration Manager -> Under Network -> Enable TCP/IP and Open properties, there you need mention port, that you want use externally

 

https://docs.microsoft.com/en-us/sql/relational-databases/sql-server-configuration-manager?view=sql-...

https://docs.microsoft.com/en-us/sql/database-engine/configure-windows/configure-client-protocols?vi...



Power BI Features || Datamarts: https://youtu.be/8tskWsJTEpg || Field Parameters : https://youtu.be/lqF3Wa1FllE?t=70
Time Intelligence Decoded : https://youtu.be/aU2aKbnHuWs&t=145s
Did I answer your question? Mark my post as a solution! Appreciate your Kudos !! Proud to be a Super User! !!
Dashboard of My Blogs !! Connect on Linkedin !! Subscribe to my youtube Channel !!
Want To Learn Power BI | Beginners !! Advance Concepts !! Power BI For Tableau User !!

Helpful resources

Announcements
August 1 episode 9_no_dates 768x460.jpg

The Power BI Community Show

Watch the playback when Priya Sathy and Charles Webb discuss Datamarts! Kelly also shares Power BI Community updates.

Power BI Dev Camp Session 24 without aka link and time 768x460.jpg

Ted's Dev Camp - July 28, 2022

Watch Session 24 of Ted's Dev Camp along with past sessions!

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Top Solution Authors
Top Kudoed Authors