cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
McMur
Helper II
Helper II

Getting rid of NeuN value

I have a database coming from a .csv file. However, I am getting some cell values with "NeuN" after loading the csv file into Power Bi. These cells in original csv file have next value " NaN".

 

To make sure about the error, I edit the query and obtain a new column based on try expression. However, "HasError" is always False.

 

Is there any way of getting rid of "NewN" values? Is it possible to replace them for null or empty ones?

 

Thanks in advance!

 

 

Pic1.PNG

 

1 ACCEPTED SOLUTION

@EricHulshof Testing different things you suggest, leads me to the original csv. I added a new row and saved it again. Now, when loading into Power Bi, there is no problem at all to get rid off the NaN values. I can use "replace values" and It recognizes them perfectly. I presume there must be an error in the way csv file is built from original source. Thanks for your help!

 

View solution in original post

13 REPLIES 13
Lewis-H
Post Partisan
Post Partisan

Firstly, it's actually the DNA splicing regulator Fox-3 (Kim, Adelstein & Kawamoto, J Biol Chem. 2009;284(45):31052-61. doi: 10.1074/jbc.M109.052969) and NeuN antibodies cross-react with the synaptic protein synapsin I.
Secondly, NeuN is specific to neurons, but not all neurons express NeuN; specifically, it is not expressed by cerebellar Purkinje neurons, olfactory bulb mitral cells (Mullen, Buck & Smith, Development. 1992;116(1):201-11. http://www.ncbi.nlm.nih.gov/pubmed/1483388), sympathetic chain ganglion neurons, cortical Cajal-Retzius neurons, nor neurons of the inferior olive and dentate nuclei (Sarnat, Nochlin & Born, Brain Dev. 1998;20(2):88-94.

 

Tahreem24
Super User II
Super User II

@McMur ,

 

You can create calculated COlumn like below:

Column = IF(CONTAINSSTRING(Table[ColumnName],"NueN"),"",Table[ColumnName])
 
Don't forget to give thumbs up 👍 and accept this as a solution if it helped you.

 

Don't forget to give thumbs up and accept this as a solution if it helped you!!!

Please take a quick glance at newly created dashboards : Restaurant Management Dashboard , HR Analytics Report , Hotel Management Report, and Sales Analysis Report
calerof
Solution Supplier
Solution Supplier

Hi @McMur ,

 

You could try this. Go to Power Query, i.e. Transform Data, then select the column with NaN, change data type to Decimal Number, and then under the Transform ribbon, go to Replace Errors, and replace with 0. 

 

This way you'll get a clean numeric field.

 

Hope it helps.

 

Regards,

 

Fernando

 

Hi Calerof,

 

Thanks for your answer. Nonetheless, it is not about one column but many of them. At the same time, these columns have already a Decimal Number data type. So, what I would like to do it is select oll of them and replace the NeuN value by nulls for example. Not sure if that is possible...

 

Anonymous
Not applicable

Hi @McMur 

 

I think this issue is consistent for all columns at same row.

Hence even if you apply filter at particular column this will remove all associated rows.

 

Query editor-> and unselected only neun values from any column.

 

Thanks & regards,
Pravin Wattamwar
www.linkedin.com/in/pravin-p-wattamwar

If I resolve your problem Mark it as a solution and give kudos.

 

In the query editor you can select all column then press right mouse button and use replace values. Search for NeuN and replace with 0 or a space.

 


Quality over Quantity


Did I answer your question? Mark my post as a solution!

Proud to be a Super User!


@EricHulshof  I have already did that but it does nothing. NaN values are still there.

 

What happens if you do not pull it in as a decimal but as a text? what does it show then?

Could you maybe share anonimized sample data for me to try somethings myself?

 


Quality over Quantity


Did I answer your question? Mark my post as a solution!

Proud to be a Super User!


@EricHulshof Testing different things you suggest, leads me to the original csv. I added a new row and saved it again. Now, when loading into Power Bi, there is no problem at all to get rid off the NaN values. I can use "replace values" and It recognizes them perfectly. I presume there must be an error in the way csv file is built from original source. Thanks for your help!

 

View solution in original post

Glad i could help 😛

Please consider marking your reaction as a solution as i can be helpfull for others 🙂

Happy building! 😄

 


Quality over Quantity


Did I answer your question? Mark my post as a solution!

Proud to be a Super User!


calerof
Solution Supplier
Solution Supplier

@McMur ,

 

1. Transform Data

2. Select column with errors, i.e. Column2

3. Add conditional column

4. AddCondColumn.png

 

 

@calerof thanks for your help. As @EricHulshof suggest, I have marked my answer as a solution for this thread.

 

Anonymous
Not applicable

why don't you simply remove those values.

 

Transform date -> select any column -> uncheck NEun Value ->Close and apply.

 

Thanks & regards,
Pravin Wattamwar
www.linkedin.com/in/pravin-p-wattamwar

If I resolve your problem Mark it as a solution and give kudos.

 

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Get Ready for Power BI Dev Camp

Power BI Dev Camp - June 24th

Mark your calendars and join us for our next Power BI Dev Camp!

Top Solution Authors
Top Kudoed Authors