cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper I
Helper I

'Forecasting' not available in Options

I am trying to enable 'Forecasting' as described in https://powerbi.microsoft.com/en-us/documentation/powerbi-desktop-analytics-pane/#enable-forecasting.... But i do not see the option? I have updated January 2017 version.

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Hi @F75,

 

From the image you posted, it seems the FisicalPeriod column contains value like this "2015 1", right?

 

In Power BI, the forecasting feature utilizes built-in predictive forecasting models to automatically detect the step (monthly/weekly/annually) and seasonality in your data to provide forecasting results. In my opinion, the issue can be that the value "2015 1" can't be recognize properly. You can modify the FisicalPeriod column remove year part and remain "1" as you already provide the FisicalYear in Axis property. See:

 

q5.PNGq4.PNG

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

7 REPLIES 7
Highlighted
Helper I
Helper I

I found its no longer a preview. But still i do not still see Forecast option in analytics.forecast.JPG

 

 

 

 

Highlighted

@F75,

A similar situation is reported on this thread: https://community.powerbi.com/t5/Desktop/Where-is-Analytics-Forecasting/td-p/112406/page/2

 

Suggestions there are:

  • ensure there is no fields in Legend area and you are using Date column in Axis area; and
  • not all values as your X axis will allow for forecasting, so if that option isn't available try changing it.

I and others can't reproduce the problem.  Can you post your PBIX to OneDrive/Dropbox/GDrive for us to check, or raise it as an Issue: https://community.powerbi.com/t5/Issues/idb-p/Issues

 

Highlighted
Resident Rockstar
Resident Rockstar

Cool Dude,

 

For forecasting u should have date on X-Axis . 

 

try with X - Axis it will help to achieve your goal.

 

Thanks

Highlighted

Hi @F75,

 

From the image you posted, it seems the FisicalPeriod column contains value like this "2015 1", right?

 

In Power BI, the forecasting feature utilizes built-in predictive forecasting models to automatically detect the step (monthly/weekly/annually) and seasonality in your data to provide forecasting results. In my opinion, the issue can be that the value "2015 1" can't be recognize properly. You can modify the FisicalPeriod column remove year part and remain "1" as you already provide the FisicalYear in Axis property. See:

 

q5.PNGq4.PNG

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted

@v-qiuyu-msft yes formatting was the issue. I used CONCATENATE function and made it as Date field.
Highlighted

I had the same problem, resolved with the suggestions above (no fields in Legend area), and no filters

trend prev.png

There is also the problem to have uniformity of predictive models between 'trend line' and 'forecasting', see the above example

Highlighted

I got better looking results in PBI desktop July 2019.

I tried to create a similar looking data set.

 

PBI forecast trend test.PNG

 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Community Conference

Microsoft Power Platform Communities

Check out the Winners!

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors
Top Kudoed Authors
Users online (563)