cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
godfreyan Frequent Visitor
Frequent Visitor

Errors Uploading Custom Themes

I had made a simple custom theme a while ago that has been working fine. Then today I was playing around with custom themes from the gallery to see what they did, and when I tried to switch back to the custom theme I had been using I got an error message that it could not be uploaded. The thing is, I haven't changed anything and it had been working before. Here is the code:

 

{
    "name": "UPMC Brand Theme",
    "dataColors": ["#771b61", "#904199", "#C784E2", "#4D104A", "#0092B3", "#A9B533", "#4D104A", "#F47721", "#BB2353", "#F37F89", "#CDDC29", "#FBAF5D", "#47C6E6", "#78777A", "#BDBBBB"],
    "background":"#DBD9D6",
    "foreground": "#363533",
    "tableAccent": "#666D70",
	
}

Do you see anything here that might be causing an error?

1 ACCEPTED SOLUTION

Accepted Solutions
BhaveshPatel Super Contributor
Super Contributor

Re: Errors Uploading Custom Themes

Hi @godfreyan 

 

I can see the issue in your code

 

{
    "name": "UPMC Brand Theme",
    "dataColors": ["#771b61", "#904199", "#C784E2", "#4D104A", "#0092B3", "#A9B533", "#4D104A", "#F47721", "#BB2353", "#F37F89", "#CDDC29", "#FBAF5D", "#47C6E6", "#78777A", "#BDBBBB"],
    "background":"#DBD9D6",
    "foreground": "#363533",
    "tableAccent": "#666D70"
	
}

Remove comma at the end of table accent enumneration.

 

 

Thanks & Regards,
Bhavesh

Love the Self Service BI.
Please use the 'Mark as answer' link to mark a post that answers your question. If you find a reply helpful, please remember to give Kudos.

View solution in original post

2 REPLIES 2
BhaveshPatel Super Contributor
Super Contributor

Re: Errors Uploading Custom Themes

Hi @godfreyan 

 

I can see the issue in your code

 

{
    "name": "UPMC Brand Theme",
    "dataColors": ["#771b61", "#904199", "#C784E2", "#4D104A", "#0092B3", "#A9B533", "#4D104A", "#F47721", "#BB2353", "#F37F89", "#CDDC29", "#FBAF5D", "#47C6E6", "#78777A", "#BDBBBB"],
    "background":"#DBD9D6",
    "foreground": "#363533",
    "tableAccent": "#666D70"
	
}

Remove comma at the end of table accent enumneration.

 

 

Thanks & Regards,
Bhavesh

Love the Self Service BI.
Please use the 'Mark as answer' link to mark a post that answers your question. If you find a reply helpful, please remember to give Kudos.

View solution in original post

godfreyan Frequent Visitor
Frequent Visitor

Re: Errors Uploading Custom Themes

Thank you so much! That fixed it!

Helpful resources

Announcements
Can You Solve These Challenge

Challenge: Can You Solve These?

Find out how to participate in the first Power BI 'Can You Solve These?' challenge.

Community News & Announcements

Community News & Announcements

Get your latest community news and announcements.

Virtual Launch Event

Microsoft Business Applications October Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

Community Kudopalooza

Win Power BI Swag with Community Kudopalooza!

Each week, complete activities and be qualified in the drawing for cool Power BI Swag.

Users Online
Currently online: 198 members 2,539 guests
Please welcome our newest community members: