cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
tsilva
Helper I
Helper I

Error connecting with MySQL - Server is duplicated

Hi people,

 

I've been trying to connect in a DB in MySQL and I haven't been able to solve this trouble.

 

The MySQL connector was installed successfully and when I try to establish the connection I receive the error below:
"Connection option 'server' is duplicated"

 

tsilva_0-1594154271113.png

 

I've found the reference here: https://community.powerbi.com/t5/Desktop/Unable-to-build-up-connection-with-MySQL/td-p/1125519  although this haven't solved my problem. I also tried to clean all the connection in the PowerBI but the same error continues appearing. 

 

Does anyone have an idea on how to solve this trouble?

 

Thank you 🙂

 

1 ACCEPTED SOLUTION
tsilva
Helper I
Helper I

I've solved this situation by doing 2 steps:

 

First - I've removed the connector on version 8.0.20 and I've installed version 8.0.15. After these installation different errors begin to show, such as "Unable to connect to any of the specified MYSQL Hosts".

 

Second - I've changed the way to connect on the DB. I've been tried as 'xxx.xxx.xxx.xxx,xxxx' and I've changed to 'xxx.xxx.xxx.xxx:xxxx' replacing the comma with a colon (important: I've had tried this before installing the version 8.0.20 and it hasn't worked, just with the version 8.0.15 everything worked well)

 

Thanks to @v-deddai1-msft  and @lbendlin  for your answers 🙂

 

View solution in original post

4 REPLIES 4
tsilva
Helper I
Helper I

I've solved this situation by doing 2 steps:

 

First - I've removed the connector on version 8.0.20 and I've installed version 8.0.15. After these installation different errors begin to show, such as "Unable to connect to any of the specified MYSQL Hosts".

 

Second - I've changed the way to connect on the DB. I've been tried as 'xxx.xxx.xxx.xxx,xxxx' and I've changed to 'xxx.xxx.xxx.xxx:xxxx' replacing the comma with a colon (important: I've had tried this before installing the version 8.0.20 and it hasn't worked, just with the version 8.0.15 everything worked well)

 

Thanks to @v-deddai1-msft  and @lbendlin  for your answers 🙂

 

View solution in original post

martigas
Frequent Visitor

Thanks

v-deddai1-msft
Community Support
Community Support

Hi @tsilva ,

 

Would you please try to update your desktop to the latest version and re-install the connector: https://dev.mysql.com/downloads/connector/net/.

 

If the issue is still exist,  I suggest you  try to open a support ticket. Go to https://support.powerbi.com. Scroll down and click "CREATE SUPPORT TICKET".

 

Best Regards,

Dedmon Dai

 

lbendlin
Super User III
Super User III

can you show a sanitized version of your Power Query connection code?

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Get Ready for Power BI Dev Camp

Power BI Dev Camp - June 24th

Mark your calendars and join us for our next Power BI Dev Camp!

Top Solution Authors
Top Kudoed Authors