cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SimpleUser New Member
New Member

Error connecting to SSAS 2005: The DbpropMsmdSubqueries property was not recognized.

When I try to import data from SSAS 2005 to Power BI Desktop I receive this error:

 

 "AnalysisServices: XML for Analysis parser: The DbpropMsmdSubqueries property was not recognized."

 

I have searched the Internet and it looks like there might be a problem with correct version of the SSAS OLEDB Provider.

 

I have installed these SSAS OLEDB Provider versions:

  • 10.50.1600.1 in C:\Program Files\Microsoft Analysis Services\AS OLEDB\10\msolap100.dll
  • 12.0.2000.8 in C:\Program Files\Microsoft Analysis Services\AS OLEDB\120\msolap120.dll
  • 13.0.0.2164.0 in C:\Program Files\Microsoft Analysis Services\AS OLEDB\130\msolap130.dll

Nothing helps. 

 

The same error occurs when I try to connect to the SSAS 2005 from Microsoft Excel 2016 from Data tab. But surprisingly I can connect to the same server from the Power Pivot tab. 

 

I am using Power BI Desktop version 2.42.4611.701 64-bit on Windows 10.

 

Any ideas?

 

Thanks, 

Radek

1 ACCEPTED SOLUTION

Accepted Solutions
Moderator v-yuezhe-msft
Moderator

Re: Error connecting to SSAS 2005: The DbpropMsmdSubqueries property was not recognized.

Hi @SimpleUser,

We are not able to connect to SSAS 2005 from Power BI Desktop. When I connect to SSAS 2008 or SSAS 2005 from Power BI Desktop, I get the error message “SQL Server versions prior to SQL Server 2008 R2 RTM aren’t supported”.
1.PNG

In your scenario, please upgrade your SSAS 2005 to SSAS 2008 R2 or later, then use Power BI Desktop to connect to it.


Thanks,
Lydia Zhang

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
1 REPLY 1
Moderator v-yuezhe-msft
Moderator

Re: Error connecting to SSAS 2005: The DbpropMsmdSubqueries property was not recognized.

Hi @SimpleUser,

We are not able to connect to SSAS 2005 from Power BI Desktop. When I connect to SSAS 2008 or SSAS 2005 from Power BI Desktop, I get the error message “SQL Server versions prior to SQL Server 2008 R2 RTM aren’t supported”.
1.PNG

In your scenario, please upgrade your SSAS 2005 to SSAS 2008 R2 or later, then use Power BI Desktop to connect to it.


Thanks,
Lydia Zhang

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.