Showing results for 
Search instead for 
Did you mean: 
New Member

Error Unable to Load Visual: Join Paths are expected to Form a Tree. Two Join Paths To Table



I'm getting the above error when applying RLS.


The error is most likely caused by the fact that I have visuals that use the same tables, but with two different relationships.


I have a Job table that has 3 relationships to a User table (created_by, completed_by, paid_by). Only one relationship is active and none of the relationships are bidirectional. In some controls on my report, I use both the created_by and the completed_by, created_by being the active relationship and completed_by being used with USERELATIONSHIP.


As soon as I apply any filter with RLS, the two controls that use the completed_by relationship break and show the above error message.


I've already tried to find a solution to this within these forums, but the similar cases I found were due to something different; usually bidirectional relationships or multiple filters on the same table in RLS.


Has anyone come accross this issue ? Any suggestions ?


Thank you

Resident Rockstar
Resident Rockstar

Hi @yvigeant,


Have you tested role in Power BI Desktop?


You could test if the visual could be loaded with removing the RLS?


Remove the multiple relationsships and create a simple relationship to have a test if it could work?


In addition, you could have a reference of this similar thread which has been solved.


If you need additional help please share some data sample which can reproduce the scenario, so that we can help further investigate on it? You can upload it to OneDrive or Dropbox and post the link here. Do mask sensitive data before uploading.)


Best Regards,


Community Support Team _ Cherry Gao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.



Thank you for your reply.


I am using Power BI Desktop.


The visuals load fine without RLS.


I cannot have a single relationship, since I am using more than one in my visuals and that requires the relationships to exist in Power BI, else USERELATIONSHIP does not work.


I have read the thread that you mentionned as well as a couple more that are related to this issue, but in all cases, the problem or solutions do not apply to my case. For instance, the one you linked had more than one filter applied in multiple tables for RLS, which is not my case.


Here is an example file that reproduces the issue. Please note that you have to select the "View as role" option with the Test role selected.


Thank you for your help.


Has no one else experienced this issue ?



Did you find solution to this problem?

Helpful resources


Happy New Year from Power BI

This is a must watch for a message from Power BI!

December Update

Check it Out!

Click here to read more about the December 2020 Updates!

Community Blog

Check it Out!

Click here to read the latest blog and learn more about contributing to the Power BI blog!

Get Ready for Power BI Dev Camp

Get Ready for Power BI Dev Camp

Mark your calendars and join us for our next Power BI Dev Camp!.

Top Solution Authors
Top Kudoed Authors