cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Enable R Script Visuals - Not saving setting

Using the July 2020 (x64, 2.83.5894.881) and earlier versions of PBI Desktop, I was able to enable R scripting visuals & have that setting saved within the .pbix file - allowing me to run scripts without interaction.

 

Subsequent versions of PBID have not saved the "Enable Script Visuals" setting, requiring me to interactively "Enable" scripting each time the file opens.

 

Suggestions?

2 REPLIES 2
Highlighted
Microsoft
Microsoft

Hi @tdhood ,

 

Try to turn this option off

options and settings->options->security.

V-lianl-msft_0-1600679955345.png

 

 

Best Regards,
Liang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Highlighted

@V-lianl-msft 

No joy.

 

Changing this setting has no effect. For what it's worth, these are not custom visuals - I'm using the native "R Script Visual" that's included with PBI-D.

 

tdhood_0-1600784630481.png

 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Community Conference

Microsoft Power Platform Communities

Check out the Winners!

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors
Top Kudoed Authors