Showing results for 
Search instead for 
Did you mean: 
Frequent Visitor

Enable R Script Visuals - Not saving setting

Using the July 2020 (x64, 2.83.5894.881) and earlier versions of PBI Desktop, I was able to enable R scripting visuals & have that setting saved within the .pbix file - allowing me to run scripts without interaction.


Subsequent versions of PBID have not saved the "Enable Script Visuals" setting, requiring me to interactively "Enable" scripting each time the file opens.



Frequent Visitor

I also have this issue. I have a number of R visuals based on scripts I wrote using the embedded R scripting ability. When I check them in R studio (my IDE) they work fine, and trhey all used to render perfectly on PBI desktop. Since very recently, they seem to be stuck in a loop where the "select to enable" pop-up simply keeps popping up preventing the visual from being shown - my visuals are now useless. I may open a fresh question for this.

Community Support
Community Support

Hi @tdhood ,


Try to turn this option off

options and settings->options->security.




Best Regards,
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.


No joy.


Changing this setting has no effect. For what it's worth, these are not custom visuals - I'm using the native "R Script Visual" that's included with PBI-D.




I am also having this issue. Were you ever able to find a solution?

Helpful resources

UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.