cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Enable Load creates an issue with tables

Hi guys,

 

I am creating a model and I am running into Memory issues. 

 

Here the setup:

- I use we service to connect to some Business Central sites (one for each company)

- I retrieve just the tables I need

- I merge the tables (same structure among companies) from the different companies into onePower BI 2.jpgPower BI1.jpg

 

In order to save some memory, I disable "Enable Load" as I will onmly need the table for all companies combined, not the temporary table.

 

When I load the model, each table "fails to resolve the name of each temporary table". 

 

Any suggetion how to solve this?

 

Thanks,

Alex

6 REPLIES 6
Highlighted
Super User IX
Super User IX

Re: Enable Load creates an issue with tables

@allejot , refer if this can help

https://www.thebiccountant.com/2016/11/08/speed-powerbi-power-query-design-process/



Did I answer your question? Mark my post as a solution! Appreciate your Kudos!!
Dashboard of My Blogs !! YouTube Channel !! Connect on Linkedin

Proud to be a Super User!

Highlighted
Frequent Visitor

Re: Enable Load creates an issue with tables

not exactly the answer to my question. I read your post but I do not want to go down that way. I want to simply not load many temporary tables.

Highlighted
Community Support
Community Support

Re: Enable Load creates an issue with tables

Hi @allejot ,

 

Please refer to the article.

Performance Tip for Power BI; Enable Load Sucks Memory Up 

 

Best regards,
Lionel Chen

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Highlighted
Frequent Visitor

Re: Enable Load creates an issue with tables

I did refer to that article when disabling "Enable Load". 

 

The issue is that by disabling "Enable Load" the table shows the error on the image I posted...

Highlighted
Community Support
Community Support

Re: Enable Load creates an issue with tables

Hi @allejot,

 

Has your problem been solved?

Did you hide the temporary table first and then use DAX to get the calculated table?

Like this?

Step1

v-lionel-msft_0-1595578824171.png

Step2

v-lionel-msft_1-1595578862791.png

You should combine the tables in ‘Edit Query’ and then cancel the ‘Enable load’ feature.

My guess is that your process of combining tables is incorrect.

v-lionel-msft_2-1595579036349.png

 

Best regards,
Lionel Chen

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

 

 

 

Highlighted
Super User IV
Super User IV

Re: Enable Load creates an issue with tables

Hi @allejot ,

 

Are the table names in your UNION statement right?

Also ideally you should merge them in Query editor, so that ou can disable the tables load (used for merging) in Query Editor.

 

Looks like you have disabled the Load of all the tables used in this UNION statement.

 

  1. Try merging these tables a s a new table in Query editor.
  2. Then disable their load in Query Editor.
  3. Just bring in the MERGED table.

Thanks,

Pragati





If this helps, Appreciate a KUDOS!
Did I answer your question? Mark my post as a solution!


Proud to be a Super User!




Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Upcoming Events

Experience what’s next for Power BI

See the latest Power BI innovations, updates, and demos from the Microsoft Business Applications Launch Event.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Get Ready for Power BI Dev Camp

Get Ready for Power BI Dev Camp

Mark your calendars and join us for our next Power BI Dev Camp!.

Top Solution Authors
Top Kudoed Authors
Users online (721)